To and Fro-2039

To and Fro
Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 8647
Accepted: 5808

Description

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There’s no place like home on a snowy night" and there are five columns, Mo would write down 
t o i o y

h p k n n

e l e a i

r a h s g

e c o n h

s e m o t

n l e w x

Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character "x" to pad the message out to make a rectangle, although he could have used any letter. 

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as 

toioynnkpheleaigshareconhtomesnlewx 

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one. 

Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

Sample Output

theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

Source

算法思想:

站在巨人的肩膀上竟然如此有成就感,算法借鉴别人的,具体算法如下:
1.得到信件中字符串的长度,一共len个字母,因为题意中肯定是矩形,所以我们用len/n将得到有几行,注意,从0行开始到 len/n - 1行;
2.然后每一行有n个数字,我们为了使数组下表不改变,就从0个字母到第n-1个字母,也就是i的标记作用;
3.最关键的就是分行,如果为第0,2,4,6...等偶数行,就打印第0个,第6个,第12个...字母;
4.如果为奇数行1,3,5...行,就打印第5,11,17...个字母;注意,行数从0开始;
5.然后根据i来打印第0,1,2...n-1列字母,从而我们得到数字规律如下:
偶数行:putchar(str[i + n*j])
奇数行:putchar(str[(n-1-i)+ n*j])
代码实现如下:

/***********************************************************************
    Copyright (c) 2015,wangzp
    All rights no reserved.
  
    Name: 《To and Fro》In PEKING UNIVERSITY ACM
    ID:   PROBLEM 2039
    问题简述: 根据规则翻译信件内容。
    Date: Aug 26, 2015 
 
***********************************************************************/
#include "stdio.h" 
#include "string.h"
#define  LEN 201
int main(void)
{
	char str[LEN];
	int i,j,len,n;
	while(scanf("%d",&n),n != 0)
	{
		scanf("%s",str);
		len = strlen(str);
		for(i = 0;i < n;i++)
		{
			for(j = 0;j < len/n;j++)
			{
				if(j % 2 == 0) 
				{
					putchar(str[i + n*j]);
				}
				else
				{
					putchar(str[(n-1-i)+ n*j]);
				}
			}           
		}
		putchar('\n');           
	}     
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值