poj2075 Tangled in Cables

题目:

Description
You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.
Input
Only one town will be given in an input.
The first line gives the length of cable on the spool as a real number.
The second line contains the number of houses, N
The next N lines give the name of each house’s owner. Each name consists of up to 20 characters {a–z,A–Z,0–9} and contains no whitespace or punctuation.
Next line: M, number of paths between houses
next M lines in the form
< house name A > < house name B > < distance >
Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.
Output
The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output
Not enough cable
If there is enough cable, then output
Need < X > miles of cable
Print X to the nearest tenth of a mile (0.1).
Sample Input
100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0
Sample Output
Need 10.2 miles of cable

题目很长,但意思简单,就是给你两个点和它们之间的距离。问要想连通所有的点最短需要多少距离(不能超过估计的距离,否则无法连通)。

这道题就是求最小生成树,可以用Kruskal算法,但要注意一些细节。

参考代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <map>
using namespace std;
const int N = 1000000+10;
double money;//距离的最大限制;
int n,m;
map<string, int> point;//这道题由于点的编号是字符串,因此可以用map;
int par[N];//每个点的根结点;
int ranki[N];//树的高度;
struct edge {
    int u,v;
    double cost;
} e[N];//边;
bool cmp(edge a, edge b) {
    return a.cost < b.cost;//最小生成树 按权值排序(小的先考虑);
}
void init() {//初始化;
    point.clear();
    memset(e, 0, sizeof(e));
    memset(par, 0, sizeof(par));
    for (int i = 0;i < n;++i) {
        ranki[i] = 1;
    }
}
void input() {
    string s;
    for (int i = 0;i < n;++i) {
        cin >> s;
        point.insert(make_pair(s, i));//输入值,string为键,int为值;
        par[i] = point[s];
    }
}

void add() {
    string s1,s2;
    double dist;
    for (int i = 0;i < m;++i) {
        cin >> s1 >> s2;
        scanf("%lf", &dist);
        e[i].u = point[s1];
        e[i].v = point[s2];
        e[i].cost = dist;
    }
}

int find(int x) {//查询树的根;
    if (par[x] == x) {
        return x;
    }
    else {
        return par[x] = find(par[x]);
    }
}
void unite(int x, int y) {//合并x和y所属的集合;
    x = find(x);
    y = find(y);
    if (x != y) {
        if (ranki[x] >= ranki[y]) {
            par[y] = x;
            ranki[x] += ranki[y];
        }
        else {
            par[x] = y;
            ranki[y] += ranki[x];
        }
    }
}
int main() {
    while (scanf("%lf", &money) != EOF) {
        scanf("%d", &n);
        init();
        input();
        scanf("%d", &m);
        add();
        sort(e, e+m, cmp);
        //for (int i = 0;i < m;++i) {
        //  cout << e[i].cost << endl;
        //}
        double ans = 0;
        for (int i = 0;i < m;++i) {
            if (find(e[i].u) != find(e[i].v)) {
                unite(e[i].u, e[i].v);
                //cout << e[i].cost << endl;
                ans += e[i].cost;       
            }
        }
        if (ans <= money) {
            printf("Need %.1f miles of cable\n", ans);
        }
        else {
            printf("Not enough cable\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值