洛谷P1550 USACO08OCT]打井Watering Hole

题目背景

John的农场缺水了!!!

题目描述

Farmer John has decided to bring water to his N (1 <= N <= 300) pastures which are conveniently numbered 1..N. He may bring water to a pasture either by building a well in that pasture or connecting the pasture via a pipe to another pasture which already has water.

Digging a well in pasture i costs W_i (1 <= W_i <= 100,000).

Connecting pastures i and j with a pipe costs P_ij (1 <= P_ij <= 100,000; P_ij = P_ji; P_ii=0).

Determine the minimum amount Farmer John will have to pay to water all of his pastures.

POINTS: 400

农民John 决定将水引入到他的n(1<=n<=300)个牧场。他准备通过挖若

干井,并在各块田中修筑水道来连通各块田地以供水。在第i 号田中挖一口井需要花费W_i(1<=W_i<=100,000)元。连接i 号田与j 号田需要P_ij (1 <= P_ij <= 100,000 , P_ji=P_ij)元。

请求出农民John 需要为使所有农场都与有水的农场相连或拥有水井所需要的钱数。

输入输出格式

输入格式:

 

第1 行为一个整数n。

第2 到n+1 行每行一个整数,从上到下分别为W_1 到W_n。

第n+2 到2n+1 行为一个矩阵,表示需要的经费(P_ij)。

 

输出格式:

 

只有一行,为一个整数,表示所需要的钱数。

 

输入输出样例

输入样例#1: 

4
5
4
4
3
0 2 2 2
2 0 3 3
2 3 0 4
2 3 4 0

输出样例#1: 

9
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int n,m;
long long ans;
struct node{
	int x;
	int y;
	int z;
}a[100005];
int s[100055];
int fa[100005];
int cnt=0;
bool cmp(const node &x,const node &y)
{
	return x.z<y.z;
}
int find(int x)
{
	if(fa[x]==x)
	{
		return x;
	}
	return fa[x]=find(fa[x]);
}
void kkk()
{
	int f1;
	int f2;
	int k=0;
	for(int i=1;i<=n;i++)
	fa[i]=i;
	for(int i=1;i<=cnt;i++)
	{
		f1=find(a[i].x);
		f2=find(a[i].y);
		if(f1!=f2)
		{
			ans=ans+a[i].z;
			fa[f1]=f2;
			k++;
			if(k==n-1)
			break;
		}
	}
} 
int main(){
	cin>>n;
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&s[i]);
	}
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
		{
			scanf("%d",&a[++cnt].z);
			a[cnt].x=i;
			a[cnt].y=j;
		}
		a[++cnt].x=i;
		a[cnt].y=n+1;
		a[cnt].z=s[i];
	}
	n++;
	sort(a+1,a+1+cnt,cmp);
	kkk();
	cout<<ans<<endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值