数据结构实验之栈与队列三:后缀式求值

数据结构实验之栈与队列三:后缀式求值

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

对于一个基于二元运算符的后缀表示式(基本操作数都是一位正整数),求其代表的算术表达式的值。

Input

输入一个算术表达式的后缀式字符串,以‘#’作为结束标志。

Output

求该后缀式所对应的算术表达式的值,并输出之。

Example Input
59*684/-3*+#
Example Output
57
Hint

基本操作数都是一位正整数!












#include <iostream>
#include <stdlib.h>

using namespace std;

#define SIZE 100
#define ADDSIZE 10

struct S
{
    int stacksize;
    int *top,*base;
};

void Inistack(S &s)
{
    s.base=new int[SIZE];
    s.top=s.base;
    s.stacksize=SIZE;
}

void Push(S &s,int e)
{
    if(s.top-s.base>=s.stacksize)
    {
        s.base=(int *)realloc(s.base,(s.stacksize+ADDSIZE)*sizeof(int));
        s.top=s.base+s.stacksize;
        s.stacksize+=ADDSIZE;
    }
    *s.top++=e;
}

int Pop(S &s)
{
    return *--s.top;
}

int main()
{
    S s;
    Inistack(s);
    while(true)
    {
        int t1,t2;
        char c;
        cin>>c;
        if(c>='0'&&c<='9')
        {
            Push(s,c-'0');//传入数字
        }
        else
        {
            if(c=='+')
            {
                t1=Pop(s);
                t2=Pop(s);
                Push(s,t1+t2);
            }
            else if(c=='-')
            {
                t1=Pop(s);
                t2=Pop(s);
                Push(s,t2-t1);//注意t2与t1的顺序
            }
            else if(c=='*')
            {
                t1=Pop(s);
                t2=Pop(s);
                Push(s,t1*t2);
            }
            else if(c=='/')
            {
                t1=Pop(s);
                t2=Pop(s);
                Push(s,t2/t1);
            }
            else if(c=='#')
            {
                break;
            }
        }
    }
    cout<<*(s.top-1)<<endl;
    return 0;
}






























  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值