HDU-5533 Dancing stars on me

The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.

Input The first line contains a integerT indicating the total number of test cases. Each test case begins with an integer, denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi, describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000

All coordinates are distinct. Output For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes). Sample Input
3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0
Sample Output
NO
YES
NO
题目大意:判断给出的坐标可不可以构成正m边形
 
 
首先要知道,因为坐标是整数,只有当 m == 4 的时候才有可能是正方形,别的都不可能
所以只要判断是不是正方形就 ok 了, 可是给出的坐标不一定是按照顺序给出的,所以要判断一下,让他按照顺序给出

#include <cstdio>
#define MAXN 1100
#define INF 0x3f3f3f3f
double x[MAXN],y[MAXN];
double map[MAXN][MAXN];
double fun(int i,int j)
{
	return (x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
}
int main()
{
	int T;
	int N;
	int i,j;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&N);
		for(i=1;i<=N;++i)
		{
			scanf("%lf%lf",x+i,y+i);
		}
		double min=INF;
		for(i=1;i<=N;++i)
		{
			for(j=i+1;j<=N;++j)
			{
				map[i][j]=fun(i,j);
				if(min>map[i][j])
				{
					min=map[i][j];
				}
			}
		}
		int cnt=0;
		for(i=1;i<=N;++i)		
			for(j=i+1;j<=N;++j)				
				if(min==map[i][j])				
					cnt++;
		if(cnt==N) printf("YES\n");
		else printf("NO\n");			
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值