SDUT-2424 Catch That Cow

27 篇文章 1 订阅
18 篇文章 0 订阅

Catch That Cow

Time Limit: 2000MS  Memory Limit: 65536KB
Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Example Input
5 17
Example Output
4
Hint
poj3278 有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。 
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题意:一条线上,农夫位于位置N,牛位于位置K,农夫有三种前进方式:1.N-1 2.N+1 3.N*2. 求出农夫抓到牛所用的最短时间
#include<bits/stdc++.h>
using namespace std;
const int ma=1000000;
int n,k,Map[ma+10];///需要设立一个记录步数的变量
struct node
{
    int step;
    int data;
} s1,s2;///此题不要用多个结构体变量解答,会超内存,用q2对三种情况分别判断
queue<node>q;
int check(int x)
{
    if(x<0||x>=ma||Map[x]==1)
    {
        return 0;
    }
    else
        return 1;
}
int BFS(int x)
{
    s1.data=x;
    s1.step=0;
    Map[x]=1;//已走过该点
    q.push(s1);
    while(!q.empty())
    {
        s1=q.front();
        q.pop();
        if(s1.data==k)
            return s1.step;
        s2.data=s1.data+1;
        if(check(s2.data))
        {
            s2.step=s1.step+1;
            Map[s2.data]=1;
            q.push(s2);
        }
        s2.data=s1.data-1;
        if(check(s2.data))
        {
            s2.step=s1.step+1;
            Map[s2.data]=1;
            q.push(s2);
        }
        s2.data=s1.data*2;
        if(check(s2.data))
        {
            s2.step=s1.step+1;
            Map[s2.data]=1;
            q.push(s2);
        }
    }
    return -1;
}
int main()
{
    int ans;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(Map,0,sizeof(Map));
        while(!q.empty()) q.pop();//注意调用前先清空,再就是不存在q.clear()
        ans=BFS(n);
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值