Catch That Cow
Time Limit: 2000MS
Memory Limit: 65536KB
Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Example Input
5 17
Example Output
4
Hint
poj3278 有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题意:一条线上,农夫位于位置N,牛位于位置K,农夫有三种前进方式:1.N-1 2.N+1 3.N*2. 求出农夫抓到牛所用的最短时间
#include<bits/stdc++.h>
using namespace std;
const int ma=1000000;
int n,k,Map[ma+10];///需要设立一个记录步数的变量
struct node
{
int step;
int data;
} s1,s2;///此题不要用多个结构体变量解答,会超内存,用q2对三种情况分别判断
queue<node>q;
int check(int x)
{
if(x<0||x>=ma||Map[x]==1)
{
return 0;
}
else
return 1;
}
int BFS(int x)
{
s1.data=x;
s1.step=0;
Map[x]=1;//已走过该点
q.push(s1);
while(!q.empty())
{
s1=q.front();
q.pop();
if(s1.data==k)
return s1.step;
s2.data=s1.data+1;
if(check(s2.data))
{
s2.step=s1.step+1;
Map[s2.data]=1;
q.push(s2);
}
s2.data=s1.data-1;
if(check(s2.data))
{
s2.step=s1.step+1;
Map[s2.data]=1;
q.push(s2);
}
s2.data=s1.data*2;
if(check(s2.data))
{
s2.step=s1.step+1;
Map[s2.data]=1;
q.push(s2);
}
}
return -1;
}
int main()
{
int ans;
while(scanf("%d%d",&n,&k)!=EOF)
{
memset(Map,0,sizeof(Map));
while(!q.empty()) q.pop();//注意调用前先清空,再就是不存在q.clear()
ans=BFS(n);
printf("%d\n",ans);
}
return 0;
}