Catch That Cow
Time Limit: 2000 ms Memory Limit: 65536 KiB
Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
poj3278 有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source
采用队列来记录路径
纯c代码如下:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int q[200002];
int book[200002];
int main()
{
int n, m,l, r;
scanf("%d%d", &n, &m);
if(n > m) printf("%d\n", n - m);
else
{
l = 0; r = 1;
memset(book, -1, sizeof(book));
q[0] = m;
book[m] = 0;
while(l < r)
{
if(q[l] != 0)
{
if(book[q[l] - 1] == -1)
{
q[r++] = q[l] - 1;
book[q[l] - 1] = book[q[l]] + 1;
}
}
if(book[q[l] + 1] == -1)
{
q[r++] = q[l] + 1;
book[q[l] + 1] = book[q[l]] + 1;
}
if(q[l] % 2 == 0 && book[q[l] / 2] == -1)
{
q[r++] = q[l] / 2;
book[q[l] / 2] = book[q[l]] + 1;
}
if(q[n] == -1)
break; //printf("%d*******%d\n", q[l], book[q[l]]); 可以查看途径
l++;
}
printf("%d\n", book[n]);
}
return 0;
}