SDUT-1959 简单枚举类型(JAVA*)

48 篇文章 2 订阅

简单枚举类型——植物与颜色

Time Limit: 1000 ms  Memory Limit: 65536 KiB
Problem Description
 请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don't know about the color purple.
 
Input
 输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。
Output
 输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don't know about the color purple.
 
Sample Input
blue
yellow
purple
Sample Output
Bluebells are blue.
Sunflower are yellow.
I don't know about the color purple.
Hint
 请用枚举类型实现。
Source

lxh

查看原文

import java.util.*;

enum Color {
	red("Rose","red"),
	orange("Poppies","orange"),
	yellow("Sunflower","yellow"),
	green("Grass","green"),
	blue("Bluebells","blue"),
	violet("Violets","violet");
	String name;
	String color;
	Color(String name, String color)
	{
		this.name=name;
		this.color=color;
	}
	public String toString()
	{
		return name+" are "+color+".";
	}
	
}
public class Main {
	public static void main(String args[]) {
		Scanner cin = new Scanner(System.in);
        while(cin.hasNextLine())
        {
        	String c=cin.nextLine();
        	try
        	{
        		Color color=Color.valueOf(c);//返回枚举类型中与c一致的变量
        		System.out.println(color);
        	}
        	catch(Exception e)
        	{
        		System.out.println("I don't know about the color "+c+".");
        	}
        }
		cin.close();
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值