HDU-ACM2057

A + B Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21898    Accepted Submission(s): 9464


Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
 

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
 

Output
For each test case,print the sum of A and B in hexadecimal in one line.
 

Sample Input
  
  
+A -A +1A 12 1A -9 -1A -12 1A -AA
 

Sample Output
  
  
0 2C 11 -2C -90

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner input=new Scanner(System.in);
        while (input.hasNext()){
            
            String stra=input.next();
            char []ch_stra=stra.toCharArray();
            String cha=""+stra.charAt(0);
            if (cha.equals("+")||cha.equals("-")){
                stra=new String(ch_stra,1,ch_stra.length-1);
            }
            
            String strb=input.next();
            char []ch_strb=strb.toCharArray();
            String chb=""+strb.charAt(0);
            if (chb.equals("+")||chb.equals("-")){
                strb=new String(ch_strb,1,ch_strb.length-1);
            }
            long a=Long.parseLong(stra,16);
            if (cha.equals("-")){
                a=-a;
            }
            long b=Long.parseLong(strb,16);
            if (chb.equals("-")){
                b=-b;
            }
            long sum=a+b;
            if (sum>=0){
                stra=Long.toHexString(sum).toUpperCase();
                System.out.println(stra);
            }else{
                sum=-sum;
                stra=Long.toHexString(sum).toUpperCase();
                System.out.println("-"+stra);
            }
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值