训练之线段树A Simple Problem with Integers

A Simple Problem with Integers Crawling in process... Crawling failed Time Limit:5000MS     Memory Limit:131072KB     64bit IO Format:%lld & %llu

Description

Input

Output

Sample Input

Sample Output

Hint

Description

给出了一个序列,你需要处理如下两种询问。

"C a b c"表示给[a, b]区间中的值全部增加c (-10000 ≤ c ≤ 10000)。

"Q a b" 询问[a, b]区间中所有值的和。

Input

第一行包含两个整数N, Q。1 ≤ N,Q ≤ 100000.

第二行包含n个整数,表示初始的序列A (-1000000000 ≤ Ai ≤ 1000000000)。

接下来Q行询问,格式如题目描述。

Output

对于每一个Q开头的询问,你需要输出相应的答案,每个答案一行。

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15
对一组数的多次更新维护用线段树,但如果用它给定的区间去依次单点更新会超时,就需要区间更新,这时引入延迟更新概念,即只是在需要更新的这一段上加上一个标记,当再次被更新时才向下传递。树若从1开始创建,左子叶为2,右子叶为3,k的左子叶为2*k,右子叶为2*k+1,若从0开始创建,k的左子叶为2*k+1,右子叶为2*k+2。

#include<stdio.h>
#define LL long long
int n,m,a[100010];
struct tree{
    int l,r;
    LL v,m;
}t[400000];//结构体树
void build(int root,int l,int r){//构建树
    t[root].l=l,t[root].r=r,t[root].m=0;
    if(l==r){
        t[root].v=a[l];
        return ;
    }
    int mid=(t[root].l+t[root].r)/2;
    build(root*2,l,mid);
    build(root*2+1,mid+1,r);
    t[root].v=t[root*2].v+t[root*2+1].v;
}
void pushup(int root){//子叶向上传递更新值
    t[root].v=t[root*2].v+t[root*2+1].v;
}
void pushdown(int root){//向下传递更新值
    if(t[root].m){
        t[root*2].m+=t[root].m;
        t[root*2].v+=t[root].m*(t[root*2].r-t[root*2].l+1);
        t[root*2+1].m+=t[root].m;
        t[root*2+1].v+=t[root].m*(t[root*2+1].r-t[root*2+1].l+1);
        t[root].m=0;
    }
}
LL query(int root,int l,int r){//查询区间和
    if(t[root].l>=l&&r>=t[root].r)  return t[root].v;
    pushdown(root);
    int mid=(t[root].l+t[root].r)/2;
    if(mid>=r){
        return query(root*2,l,r);
    }
    else if(mid<l){
        return query(root*2+1,l,r);
    }
    else{
        return query(root*2,l,mid)+query(root*2+1,mid+1,r);
    }
}
void updata(int root,int l,int r,LL add){//更新区间
    int mid=(t[root].l+t[root].r)/2;
    if(t[root].l>=l&&r>=t[root].r){
        t[root].m+=add;
        t[root].v+=(t[root].r-t[root].l+1)*add;
        return ;
    }
    pushdown(root);
    if(mid>=r){
        updata(root*2,l,r,add);
    }
    else if(mid<l){
        updata(root*2+1,l,r,add);
    }
    else{
        updata(root*2,l,mid,add);
        updata(root*2+1,mid+1,r,add);
    }
    pushup(root);
}
int main(){
    scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        build(1,1,n);
        while(m--){
            char str[10];
            int l,r,x;
            scanf("%s",str);
            if(str[0]=='Q'){
                scanf("%d%d",&l,&r);
                LL ans=query(1,l,r);
                printf("%lld\n",ans);
            }
            if(str[0]=='C'){
                scanf("%d%d%lld",&l,&r,&x);
                updata(1,l,r,x);
            }
        }
    return 0;
}


Here is a C++ program that constructs a max heap with integers and prints it in the rotated form: ```cpp #include <iostream> #include <vector> using namespace std; // function to swap two integers void swap(int& a, int& b) { int temp = a; a = b; b = temp; } // function to heapify the given vector void heapify(vector<int>& arr, int n, int i) { int largest = i; // initialize largest as root int left = 2*i + 1; // left child index int right = 2*i + 2; // right child index // if left child is larger than root if (left < n && arr[left] > arr[largest]) largest = left; // if right child is larger than largest so far if (right < n && arr[right] > arr[largest]) largest = right; // if largest is not root if (largest != i) { // swap the root with largest element swap(arr[i], arr[largest]); // recursively heapify the affected sub-tree heapify(arr, n, largest); } } // function to build max heap void buildMaxHeap(vector<int>& arr, int n) { // start from the last non-leaf node and heapify each node for (int i = n / 2 - 1; i >= 0; i--) heapify(arr, n, i); } // function to print the heap in the rotated form void printRotatedHeap(vector<int>& arr, int n) { int height = log2(n) + 1; // height of the heap int index = 0; // current index in the heap int spaces = pow(2, height - 1) - 1; // number of spaces before the first element of the current level // print each level of the heap in the rotated form for (int i = 0; i < height; i++) { // print the spaces before the first element of the current level for (int j = 0; j < spaces; j++) cout << " "; // print the elements of the current level for (int j = 0; j < pow(2, i) && index < n; j++) { cout << arr[index++] << " "; // print the spaces between elements of the current level for (int k = 0; k < 2 * spaces + 1; k++) cout << " "; } // move to the next line and adjust the number of spaces for the next level cout << endl; spaces /= 2; } } int main() { int n; cout << "Enter the number of elements: "; cin >> n; vector<int> arr(n); cout << "Enter the elements: "; for (int i = 0; i < n; i++) cin >> arr[i]; // build max heap buildMaxHeap(arr, n); // print the heap in the rotated form cout << "Max heap in the rotated form:\n"; printRotatedHeap(arr, n); return 0; } ``` In this program, we first define a `swap` function to swap two integers, and a `heapify` function to heapify the sub-tree rooted at a given index `i` in the given vector `arr`. We then define a `buildMaxHeap` function to build the max heap from the given vector `arr`. Finally, we define a `printRotatedHeap` function to print the max heap in the rotated form. In the `main` function, we first read the number of elements and the elements themselves from the user using `cin`. We then build the max heap using `buildMaxHeap` function, and print the heap in the rotated form using `printRotatedHeap` function. The `printRotatedHeap` function uses the height of the heap to determine the number of levels, and the number of spaces before the first element of each level. It then prints each level of the heap in the rotated form, by printing the elements of the level followed by the spaces between elements.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值