A Simple Problem with Integers - 线段树(改变区间的值)

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.

分析:

WA了无数次,终于AC了……不容易……

首先 The sums may exceed the range of 32-bit integers.说明要用long long了,把sum数组和add数组都设成long long型所以对应查询函数的返回值也要是long long型。其次,写线段树一定要细心啊,中间拼错一个字母……debug了好久……

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define ll long long
#define lson l,m,k<<1
#define rson m+1,r,k<<1|1

const int N=100003;
ll sum[N<<2],add[N<<2];

void push_up(int k){
    sum[k]=sum[k<<1]+sum[k<<1|1];
}
void push_down(int k,int m){
    if(add[k]){
        add[k<<1]+=add[k];
        add[k<<1|1]+=add[k];
        sum[k<<1]+=add[k]*(m-(m>>1));
        sum[k<<1|1]+=add[k]*(m>>1);
        add[k]=0;
    }
}
void build(int l,int r,int k){
    if(l==r){
        scanf("%lld",&sum[k]);
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    push_up(k);
}

void update(int L,int R,int c,int l,int r,int k){
    if(L<=l&&R>=r){
        sum[k]+=(ll)c*(r-l+1);
        add[k]+=c;
        return ;
    }
    push_down(k,r-l+1);
    int m=(l+r)>>1;
    if(L<=m)update(L,R,c,lson);
    if(R>m)update(L,R,c,rson);
    push_up(k);
}

ll query(int L,int R,int l,int r,int k){
    if(L<=l&&R>=r)return sum[k];
    push_down(k,r-l+1);
    int m=(l+r)>>1;
    ll ans=0;
    if(L<=m)ans+=query(L,R,lson);
    if(R>m)ans+=query(L,R,rson);
    return ans;
}
int main(){
    int n,m,a,b,c;
    char s[4];
    scanf("%d%d",&n,&m);
    memset(sum,0,sizeof(sum));
    memset(add,0,sizeof(add));

    build(1,n,1);
    while(m--){
        scanf("%s",s);
        if(s[0]=='Q'){
            scanf("%d%d",&a,&b);
            printf("%lld\n",query(a,b,1,n,1));
        }
        else {
            scanf("%d%d%d",&a,&b,&c);
            update(a,b,c,1,n,1);
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值