POJ 2676 Sudoku

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18838 Accepted: 9078 Special Judge
Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.

这里写图片描述

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.
Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.
Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

题目大意:
给你一个9*9的九宫格,有部分已经填上了数字,要求将九宫格用1-9填满,每行中的数字各不相同,每列中的数字各不相同,从从第一行开始每3*3组成一个小九宫格,小九宫格中的数字也各不相同

思路:
就是简单深搜,只要注意一个地方,第k个小九宫格如何表示,k=(x/3)*3+y/3

代码:

/*************************************************************************
    > File Name: s4-f.cpp
    > Author: 
    > Mail: 
    > Created Time: 2016年10月25日 星期二 13时20分37秒
 ************************************************************************/

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int lvisit[10][10];
int hvisit[10][10];
int gvisit[10][10];
int map[10][10];
bool dfs(int x,int y)
{
    int k=(x/3)*3+y/3;
    if(x==9)
        return true;
    bool flag=false;
    if(map[x][y]>0)
    {
        if(y<8)
            flag=dfs(x,y+1);
        else
            flag=dfs(x+1,0);
        return flag;
    }
    else 
    {
        for(int i=1;i<=9;i++)
        {
            if(hvisit[x][i]==0&&lvisit[y][i]==0&&gvisit[k][i]==0)
            {
                hvisit[x][i]=1;
                lvisit[y][i]=1;
                gvisit[k][i]=1;
                map[x][y]=i;
                if(y<8)
                    flag=dfs(x,y+1);
                else
                    flag=dfs(x+1,0);
                if(flag)
                    return true;
                map[x][y]=0;
                hvisit[x][i]=0;
                lvisit[y][i]=0;
                gvisit[k][i]=0;
            }
        }
    }
    return false;
}
int main()
{
    int n;
    char x;
    scanf("%d%c",&n,&x);
    while(n--)
    {
        memset(lvisit,0,sizeof(lvisit));
        memset(hvisit,0,sizeof(hvisit));
        memset(gvisit,0,sizeof(gvisit));
        char s[10];
        for(int i=0;i<9;i++)
        {
            scanf("%s",&s);
            for(int j=0;j<9;j++)
            {
                map[i][j]=s[j]-'0';
                if(map[i][j]>0)
                {
                    int item=map[i][j];
                    hvisit[i][item]=1;
                    lvisit[j][item]=1;
                    int k=(i/3)*3+j/3;
                    gvisit[k][item]=1;
                }
            }
        }
        dfs(0,0);
        for(int i=0;i<9;i++)
        {
            for(int j=0;j<9;j++)
            {
                printf("%d",map[i][j]);
            }
            printf("\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值