uva490 Rotating Sentences

19 篇文章 0 订阅

Rotating Sentences 

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left.

Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not legal characters.)

The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.

Sample Input


Rene Decartes once said,
"I think, therefore I am."
Sample Output


"R
Ie
 n
te

iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"

fgets() 吃了换行 很难发现的错误,导致最后一行输出隔了个空行
#include <stdio.h>
#include <string.h>
#define MAX 105

char set[MAX][MAX];

int main()
{
    int i, j, count = 0, length_max = 0;
    for ( ;fgets(set[count], MAX, stdin); count++)
    {
        if ((i = strlen(set[count])) > length_max)
            length_max = i;
    }
    for (i = 0; i < length_max - 1; i++)
    {
        for (j = count - 1 ; j >= 0; j--)
            if (i < strlen(set[j]) - 1)
                printf("%c", set[j][i]);
            else
                printf(" ");
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值