POJ - 3253 Fence Repair(哈夫曼树+优先队列)

Fence Repair
Time Limit: 2000MS Memory Limit: 65536K
Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.
FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.
Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.
Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input

3
8
5
8
Sample Output

34
Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 

The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).


题意是说锯木头,锯多长的木头就要收多少的钱。给出木头的块数和长度,求最小的花费。

先介绍下哈夫曼树好了:

哈夫曼树的节点带权值,并且所有权值之和最小。

假设有n个权值,则构造出的哈夫曼树有n个叶子结点.n个权值分别设为 w1、w2、…、wn,则哈夫曼树的构造规则为:
(1) 将w1、w2、…,wn看成是有n 棵树的森林(每棵树仅有一个结点);
(2) 在森林中选出两个根结点的权值最小的树合并,作为一棵新树的左、右子树,且新树的根结点权值为其左、右子树根结点权值之和;
(3)从森林中删除选取的两棵树,并将新树加入森林;

(4)重复(2)、(3)步,直到森林中只剩一棵树为止

举例

知字符A B C D E F的权值为8 12 5 20 4 11

先排序,选取最小的两个节点后出队,构造成根节点,压入队列

再选取最小的两个节点形成根节点压入队列,以此类推

哈夫曼树就是:
             60
         /            \
   23                  37
 /       \             /      \
F(11) B(12)  17      D(20)  
                   /    \              
                A(8)   9        
                        /     \

                    E(4)  C(5)

在本题中,一个大木头切成两个小木头,则两块小木头的长度就是切开大木头的花费,即:每块小木头就是一个节点,他的长度就是节点的权值。由于哈夫曼树节点有权值,且权值之和(树的带权路径长度)最小,那么只要将小木块当作节点构造哈夫曼树,最后的根节点的权值便是最小花费。

由于数据较大排序怕是会TLE。所以采用优先队列。

#include <stdio.h>
#include <iostream>
#include <queue>
#include <vector>
#include <algorithm>
#include <string.h>
#define ll long long
using namespace std;
bool cmp(ll a,ll b)
{
	return a>b;
}
priority_queue<ll,vector<ll>,greater<ll> > que;
int main ()
{
	ll m,n;
	while (~scanf ("%lld",&n)){
		ll i,j,len = 0,ans = 0;
		for (i = 0;i < n; i++){
			ll a;
			scanf ("%lld",&a);
			len += a;
			que.push(a);
		}
		
		while (!que.empty()){
			ll a = que.top();
			que.pop();
			if (que.empty()){//如果只剩一个了那么说明只剩根节点无法构造。 
				break;
			}
			ll b = que.top();
			que.pop();
			ans += a+b;//计算树的带权路径长度
			que.push(a+b);//取出两个合并后压入一个。 
		}
		cout << ans << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值