POJ3253 _ Fence Repair

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
Source

USACO 2006 November Gold

题目大意:

农夫要修理栅栏,将一块长木板切割成n快,长度分别为L1,L2,…Ln,未切割前木板的长度恰好等于切割后木板的长度的总和。
每次切开木板时,需要的开销为这块木板的长度。
例如:长度为21的木板需要切成长度5 8 8 的三块木板,
长度为21的木板切成13和8时,开销为21,再将13切成5和8时,开销是13,所以总开销是13+21 = 34,即为最小花费。
求出木板切割完最小的开销是多少。

分析

这有点像哈夫曼树,利用哈弗曼的思想即可求得正确结果。每次找两个最小的相加,再加入到序列中,继续,直到序列中只剩下一个数字。
可以利用优先队列(可以找最大值,或者最小值),每次找两个最小的,再将想加的结果存回队列中。,直到仅剩一个数字。

代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
typedef long long ll;
using namespace std;
int n;
int L[100];
void solve()
{
    int res = 0;
    //声明一个从小到大取出数值的优先队列
    priority_queue<int , vector<int >,greater<int> >que;
    //将数值加入到队列中
    for(int i=0;i<n;i++)
        que.push(L[i]);
    //循环到只剩一个数字
    while(que.size()>1)
    {
        //最小的两个数值;
        int m1;
        int m2;
        m1 = que.top();  //取出最小的一个
        que.pop();    //删除最小的
        m2 = que.top();
        que.pop();
        res = res + m1+m2;
        que.push(m1+m2);
    }
    printf("%d\n",res);
}
int main()
{
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d",&L[i]);
    solve();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值