Ternary Calculation(也不用栈,注意输入方式即可,直接解决)

Ternary Calculation

Time Limit: 2000ms
Memory Limit: 65536KB
64-bit integer IO format: %lld      Java class name: Main

Complete the ternary calculation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a string in the form of "number1 operatora number2 operatorb number3". Each operator will be one of {'+', '-' , '*', '/', '%'}, and each number will be an integer in [1, 1000].

Output

For each test case, output the answer.

Sample Input
5
1 + 2 * 3
1 - 8 / 3
1 + 2 - 3
7 * 8 / 5
5 - 8 % 3
Sample Output
7
-1
0
11
3
Note

The calculation "A % B" means taking the remainder of A divided by B, and "A / B" means taking the quotient.


#include<stdio.h>
int num[4];
char ch[3];

void input()
{
	scanf("%d",&num[1]);
	getchar();
	scanf("%c",&ch[1]);
	scanf("%d",&num[2]);
	getchar();
	scanf("%c",&ch[2]);
	scanf("%d",&num[3]);
}

int compute(int a,char op,int b)
{
	switch(op)
	{
		case'+':return a+b;break;
		case'-':return a-b;break;
		case'*':return a*b;break;
		case'/':return a/b;break;
		case'%':return a%b;break;
	}
}



char precede(char a,char b)
{
	if(a=='+'||a=='-')
	{
		if(b=='*'||b=='/'||b=='%')
			return '<';
		else
			return '=';
	}
	else
	{
		if(b=='*'||b=='/'||b=='%')
			return '=';
		else
			return '>';
	}
}

int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		
		int m,s;
		input();
		switch(precede(ch[1],ch[2]))
		{
		case '>':m=compute(num[1],ch[1],num[2]);
			s=compute(m,ch[2],num[3]);
			break;
		case'=':m=compute(num[1],ch[1],num[2]);
			s=compute(m,ch[2],num[3]);
			break;
		case'<':m=compute(num[2],ch[2],num[3]);
			s=compute(num[1],ch[1],m);
			break;
		}
		printf("%d\n",s);
	}
	return 0;
}
			


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值