杭电 1087 Super Jumping! Jumping! Jumping!

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
  
  
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
  
  
4 10

3

题意:给一串数字要求找到和最大的单调递增子序列,一行的输入分别是数字的个数和数字;本题做法和最长递增子序列做法一致,只不过保存的东西不同,一个是i之前的数字个数,一个是数字和,使用a[i]保存输入数字,b[i]保存到从第1个数到第i个数时,以i为结束的递增子序列

最大的和,那么核心代码:

  for(int j=0;j<i;j++)            {                if(a[i]>a[j])                {                    if(b[i]<a[i]+b[j])                    {                        b[i]=a[i]+b[j];                    }                }                 if(ma<b[i])                     ma=b[i];            }

#include<iostream>
#include<stdio.h>
#include<fstream>
#include<string.h>
#include<algorithm>
#define MAX 9999999
using namespace std;
int a[1050],b[1050];
int main()
{

    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        memset(b,0,sizeof(b));
        int ma=0;
       for(int i=0;i<n;i++)
       {
           scanf("%d",&a[i]);
           b[i]=a[i];
           for(int j=0;j<i;j++)
           {
               if(a[i]>a[j])
               b[i]=max(b[i],a[i]+b[j]);
               else
                b[i]=max(b[i],a[i]);
                ma=max(b[i],ma);
           }
       }
       printf("%d\n",ma);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值