Font Size

描述

Steven loves reading book on his phone. The book he reads now consists of N paragraphs and the i-th paragraph contains ai characters.

Steven wants to make the characters easier to read, so he decides to increase the font size of characters. But the size of Steven's phone screen is limited. Its width is W and height is H. As a result, if the font size of characters is S then it can only show ⌊W / S⌋ characters in a line and ⌊H / S⌋ lines in a page. (⌊x⌋ is the largest integer no more than x)  

So here's the question, if Steven wants to control the number of pages no more than P, what's the maximum font size he can set? Note that paragraphs must start in a new line and there is no empty line between paragraphs.

输入

Input may contain multiple test cases.

The first line is an integer TASKS, representing the number of test cases.

For each test case, the first line contains four integers N, P, W and H, as described above.

The second line contains N integers a1, a2, ... aN, indicating the number of characters in each paragraph.


For all test cases,

1 <= N <= 103,

1 <= W, H, ai <= 103,

1 <= P <= 106,

There is always a way to control the number of pages no more than P.

输出

For each testcase, output a line with an integer Ans, indicating the maximum font size Steven can set.

样例输入
2
1 10 4 3
10
2 10 4 3
10 10

样例输出
3
2

模拟题

题意:有n段文字可以调节字体,调节字体后每行所能显示的字会变少,屏幕的宽度为w长度为l,和字体的关系为一行能显示的字数为[w/s],一页能显示的行数为[l/s];s为字号,要求s最大且在p页能显示完,没啥好说,水题,模拟


#include<stdio.h>
#include<string.h>
#include<math.h>
#define INF 0x3fffffff
#include<iostream>
using namespace std;
int main()
{
    int N;
    scanf("%d",&N);
    while(N--)
    {
        int n,p,w,h;
        scanf("%d %d %d %d",&n,&p,&w,&h);
        int a[1010];
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        int l=0;
        for(int i=1;i<=min(w,h);i++)
        {
            int wi=w/i;///一行存几个字
            int hi=h/i;///一页存多少行
            int ans=0;
            for(int j=0;j<n;j++)
            {
                if(a[j]%wi==0)
                    ans+=a[j]/wi;
                else
                    ans+=(a[j]/wi+1);
            }
            if(ans>p*hi)
            {
                l=1;
                printf("%d\n",i-1);
                break;
            }
        }
        if(l==0)
            printf("%d\n",min(w,h));
    }
}



Sure, I can help you with that! Here's a sample code in Python using the Tkinter library: ``` from tkinter import * class FontSizer: def __init__(self, master): self.master = master master.title("Font Sizer") # create top label for "X" self.x_label = Label(master, text="X", font=("Helvetica", 18)) self.x_label.pack(pady=10) # create label for font size value self.font_size_label = Label(master, text="18", font=("Helvetica", 14)) self.font_size_label.pack(pady=10) # create bottom button to increase font size self.increase_button = Button(master, text="Increase Font Size", command=self.increase_font_size) self.increase_button.pack(side=LEFT, padx=10, pady=10) # create bottom button to decrease font size self.decrease_button = Button(master, text="Decrease Font Size", command=self.decrease_font_size) self.decrease_button.pack(side=RIGHT, padx=10, pady=10) def increase_font_size(self): font_size = int(self.font_size_label["text"]) font_size += 1 self.update_font_size(font_size) def decrease_font_size(self): font_size = int(self.font_size_label["text"]) if font_size > 1: font_size -= 1 self.update_font_size(font_size) def update_font_size(self, font_size): self.x_label.config(font=("Helvetica", font_size)) self.font_size_label.config(text=str(font_size)) # create the main window root = Tk() # create an instance of the FontSizer class font_sizer = FontSizer(root) # start the GUI root.mainloop() ``` This program creates a window with a label for the letter "X" and a label for the font size value. It also has two buttons at the bottom to increase or decrease the font size. The font size of the "X" label and the font size value label are updated whenever the user clicks on the increase or decrease buttons. To use this program, save the code in a file with a ".py" extension and run it using a Python interpreter.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值