1597

Uniform Generator
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1764 Accepted: 802

Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

 

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1<=STEP,MOD<=100000).

Output
For each line of input, your program should print the STEP value right-justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.

Sample Input

 

Sample Output

 

Source
South Central USA 1996

 

 

*********************************************************************

*********************************************************************

Source Code

Problem: 1597 User: xcl119xcl
Memory: 72K Time: 0MS
Language: C++ Result: Accepted

  • Source Code
    #include<stdio.h>
    int main()
    {
    	long stp,mod,n;
    while(scanf("%ld%ld",&stp,&mod)!=-1){	
    		printf("%10ld%10ld    ",stp,mod);
    		n=stp>mod?mod:stp;
    		for(;n>1;n--)
    			if(stp%n==0&&mod%n==0)
    				break;//判断stp和mod是否互素
    		if(n==1)
    			printf("Good Choice/n/n");
    		else
    			printf("Bad Choice/n/n");
         }
    return 0;
    }
    

         3         5    Good Choice

        15        20    Bad Choice

     63923     99999    Good Choice

3 5
15 20
63923 99999


seed(x+1) = [ seed(x) + STEP ] % MOD

where "%" is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP=3 and MOD=5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

xcl119xxcl

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值