1313 Booklet Printing

Booklet Printing
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 861 Accepted: 451

Description
When printing out a document, normally the first page is printed first, then the second, then the third, and so on until the end. However, when creating a fold-over booklet, the order of printing must be altered. A fold-over booklet has four pages per sheet, with two on the front and two on the back. When you stack all the sheets in order, then fold the booklet in half, the pages appear in the correct order as in a regular book. For example, a 4-page booklet would print on 1 sheet of paper: the front will contain page 4 then page 1, and the back will contain page 2 then page 3.

 

Input
The input contains one or more test cases, followed by a line containing the number 0 that indicates the end of the file. Each test case consists of a positive integer n on a line by itself, where n is the number of pages to be printed; n will not exceed 100.

Output
For each test case, output a report indicating which pages should be printed on each sheet, exactly as shown in the example. If the desired number of pages does not completely fill up a sheet, then print the word Blank in place of a number. If the front or back of a sheet is entirely blank, do not generate output for that side of the sheet. Output must be in ascending order by sheet, front first, then back.

Sample Input

 

Sample Output

 

Source
Mid-Central USA 1998

 **************************************************************************************

***************************************************************************************

  • Source Code
    #include <iostream>
    using namespace std;
    struct page
    {
     int pageNum[4];
    };
    int main()
    {
     int totalPages,sheets;
     page pages[26];
     int i,p,ps,temp=0,back=0;
     while(1)
     {
      cin>>totalPages;
      if( totalPages==0 ) break;
      memset(pages,0,sizeof(pages));
      sheets=totalPages/4;
      if(totalPages%4!=0) sheets++;
      back=temp=ps=0;p=-1;
      for(i=1; i<=totalPages; i++)
      {
       if( i<=sheets*2 )
       {
        if(i%2==1) p++;  
        if(temp==0)
         pages[p].pageNum[1]=i;
        else
         pages[p].pageNum[2]=i;
        temp = (temp+1)%2;
        back=0;
       }
       else
       {
        if(back==0) { p++; back=1; }
        if( i%2==1 ) p--;
        if(temp==0)
         pages[p].pageNum[3]=i;
        else
         pages[p].pageNum[0]=i;
        temp = (temp+1)%2;
       }
      } 
      cout<<"Printing order for "<<totalPages<<" pages:"<<endl;
      for(i=0;i<sheets;i++)
      {
       if( (pages[i].pageNum[0]==0 && pages[i].pageNum[1]==0) )
        continue;
       cout<<"Sheet "<<i+1<<", front: ";
       if(pages[i].pageNum[0]!=0) cout<<pages[i].pageNum[0]<<", ";
       else cout<<"Blank, ";
       if(pages[i].pageNum[1]!=0) cout<<pages[i].pageNum[1]<<endl;
       else cout<<"Blank"<<endl;
    
       if( pages[i].pageNum[2]==0 && pages[i].pageNum[3]==0 )
        continue;
       cout<<"Sheet "<<i+1<<", back : ";
       if(pages[i].pageNum[2]!=0) cout<<pages[i].pageNum[2]<<", ";
       else cout<<"Blank, ";
       if(pages[i].pageNum[3]!=0) cout<<pages[i].pageNum[3]<<endl;
       else cout<<"Blank"<<endl;
      }
     }
     return 0;
    }
    
    
  • Printing order for 1 pages:
    Sheet 1, front: Blank, 1
    Printing order for 14 pages:
    Sheet 1, front: Blank, 1
    Sheet 1, back : 2, Blank
    Sheet 2, front: 14, 3
    Sheet 2, back : 4, 13
    Sheet 3, front: 12, 5
    Sheet 3, back : 6, 11
    Sheet 4, front: 10, 7
    Sheet 4, back : 8, 9
    Printing order for 4 pages:
    Sheet 1, front: 4, 1
    Sheet 1, back : 2, 3

    1
    14
    4
    0
    


    Front Back
    ------------- -------------
    | | | | | |
    | 4 | 1 | | 2 | 3 |
    | | | | | |
    ------------- -------------

    Your task is to write a program that takes as input the number of pages to be printed, then generates the printing order.

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

xcl119xxcl

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值