1733 Parity game

Parity game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 900 Accepted: 357

Description
Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input
The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output
There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

 

Sample Output

 

Source
CEOI 1999

 ************************************************************************************

******************************************************************************************

  • Source Code
    //pku1733 Parity game
    //by oyjpArt
    /*
    Step 1:   由于端点数目远远小于数据范围 给于数据范围离散化
    Step 2:将区间问题转化成单点 sum[a,b] = sum[0,b] - sum[0, a-1];
    Step 3:   构造并查集,设置一个属性prt代表和父结点的XOR值。即:
    如果父结点为偶 prt = true 则本节点为奇
    同理可推知其他情况 构建并查集的目的是为了是查询能够在有联系的两个节点之间通过其他结点迅速判断奇偶性
    对于一个询问(l, r, p):若l-1与r是属于同一个集合,则检查l-1与r相对于根o的奇偶性差异P[l -1, o]与P[r, o]。看这两个差异值的差异是不是就是p,即P[l-1, o] xor P[r, o]是不是等于p,不是则矛盾。若l-1与r是不属于同一个集合,则将l-1与r所在树的根节点合并起来,这两个根结点间奇偶性差异为P[l-1,o] xor P[r, o] xor p。
    有构建的方式可以看出 这个并查集是可以路径压缩的
      */
    #include <map>
    #include <iostream>
    #include <string>
    using namespace std;
    const int N  = 5010;
    int x[N], y[N];
    bool odd[N];
    int p[2 * N];
    bool prt[2 * N];
    int Root(int x, bool & e)
    {
    int r = x, t = x;
    bool res = prt[x];
    while(p[r] != r)
    {
    r = p[r];
    res = res ^ prt[r];
    }
    e = res;
    return r;
    }
    void Union(int a, int b, bool e)
    {
    p[a] = b;
    prt[a] = e;
    }
    bool chk(int idx)
    {
    int a = x[idx], b = y[idx];
    bool e = odd[idx], ea, eb;
    int ra = Root(a, ea), rb = Root(b, eb);
    if(ra == rb)
    {
    if( (ea ^ eb) != e) return false;
    }
    else
    {
    Union(ra, rb, (ea ^ eb ^ e) );
    }
    return true;
    }
    int main()
    {
    //    freopen("t.in", "r", stdin);
    map<int, int> m;
    int l, i, ncmd, a, b, idx;
    string s;
    cin >> l >> ncmd;
    for(i = 0, idx = 0; i < ncmd; ++i)
    {
    cin >> a >> b >> s;
    if(a > b) swap(a, b);
    --a;
    if(a < 0)
    while(1) printf("1");
    if(!m.count(a)) m[a] = idx++;
    if(!m.count(b)) m[b] = idx++;
    x[i] = m[a]; y[i] = m[b];
    odd[i] = s[0] == 'o';
    }
    for(i = 0; i < idx; ++i) { p[i] = i; prt[i] = false; }
    for(i = 0; i < ncmd; ++i) {
    if(!chk(i))
    break;
    }
    printf("%d/n", i);
    return 0;
    }
    
  • 3

    10
    5
    1 2 even
    3 4 odd
    5 6 even
    1 6 even
    7 10 odd
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

xcl119xxcl

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值