1035 Spell checker

 
Spell checker
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 2298 Accepted: 841

Description
You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input
The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

 

Sample Output

 

Source
Northeastern Europe 1998

****************************************************************

****************************************************************

  • Source Code
    #include <stdio.h>
    #include <string.h>
    #include <stdlib.h>
    
    #define N 10001
    #define M 27
    
    char s[N][M],word[M];
    int id[N];
    
    int cmp(const void *x,const void *y) {
    int a=*(int*) x,b=*(int*) y;
    	return strcmp(s[a],s[b]);
    }
    
    int replace(char *s,char *w) {
    int lens=strlen(s),lenw=strlen(w),i,p;
    	if (lens==lenw) {
    		p=0;
    		for (i=0;i<lens;++i)
    			if (s[i]!=w[i]) {
    				if (p) return 0;
    				p=1;
    			}
    		return 1;
    	}
    	if (lens+1==lenw) {
    		i=0;
    		while ((i<lens) && (s[i]==w[i])) ++i;
    		for (++i;i<lenw;++i)
    			if (s[i-1]!=w[i]) return 0;
    		return 1;
    	}
    	if (lens==lenw+1) {
    		i=0;
    		while ((i<lenw) && (s[i]==w[i])) ++i;
    		for (++i;i<lens;++i)
    			if (s[i]!=w[i-1]) return 0;
    		return 1;
    	}
    	return 0;
    }
    
    main() {
    int z,n,i;
    	
    	for (z=1;z>0;--z) {
    		for (n=0;;++n) {
    			scanf("%s",s[n]);
    			if (s[n][0]=='#') break;
    			id[n]=n;
    		}
    		//qsort(id,n,sizeof(int),cmp);
    		while (1) {
    			scanf("%s",word);
    			if (word[0]=='#') break;
    			for (i=0;i<n;++i)
    				if (!strcmp(s[i],word)) break;
    			if (i<n) {
    				printf("%s is correct/n",word);
    				continue;
    			}
    			printf("%s:",word);
    			for (i=0;i<n;++i) 
    				if (replace(s[id[i]],word)) printf(" %s",s[id[i]]);
    			printf("/n");
    		}
    		if (z>1) printf("/n");
    	}
    }
    
  • me is correct
    aware: award
    m: i my me
    contest is correct
    hav: has have
    oo: too
    or:
    i is correct
    fi: i
    mre: more me

    i
    is
    has
    have
    be
    my
    more
    contest
    me
    too
    if
    award
    #
    me
    aware
    m
    contest
    hav
    oo
    or
    i
    fi
    mre
    #
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

xcl119xxcl

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值