POJ1035——Spell checker

Spell checker
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24534 Accepted: 8962

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source


题目大意:

开始输入字典中的单词,以#结束;

然后输入需要检测的单词,以#结束;

检测规则:(word表示要检测的单词)

如果字典中有该单词,则输出  word is correct,若相差一个字母(可以多一个、少一个或者不同一个),则输出 word: s1 s2 s3 .......


题目比较水,具体代码:

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

struct node
{
    char s[20];
    int len;
}dic[10010];      //字典

int cnt;     //字典中单词的数量

int check(char s[20])   //检查是否含有该单词  有返回1  否则返回0
{
    for( int i = 0;i < cnt;i++ )
    {
        if( strcmp(s,dic[i].s)==0 )
            return 1;
    }
    return 0;
}

void dell(char st[20])   //没有源单词,从头开始遍历
{
    int len = strlen(st);
    for( int i = 0;i < cnt;i++ )
    {
        if( len==dic[i].len )       //三种情况
        {
            int j1 = 0;
            int j2 = 0;
            int cn = 0;
            for( ;j1<len&&j2<dic[i].len; )
            {
                if( cn>1 )break;
                if( dic[i].s[j2]!=st[j1] )
                    cn++;
                j2++;
                j1++;
            }
            if( cn<=1 )
                cout<<" "<<dic[i].s;
        }
        else if( len>dic[i].len&&len-dic[i].len<=1 )
        {
            int j1 = 0;
            int j2 = 0;
            int cn = 0;
            for( ;j1<len&&j2<dic[i].len; )
            {
                if( cn>1 )break;
                if( dic[i].s[j2]==st[j1] )
                    j2++;
                else cn++;
                j1++;
            }
            if( cn<=1&&j2>=dic[i].len )
                cout<<" "<<dic[i].s;
        }
        else
        {
            if( dic[i].len>len&&dic[i].len-len<=1 )
            {
                int j1 = 0;
                int j2 = 0;
                int cn = 0;
                for( ;j1<len&&j2<dic[i].len; )
                {
                    if( cn>1 )break;
                    if( dic[i].s[j2]==st[j1] )
                        j1++;
                    else cn++;
                    j2++;
                }
                if( cn<=1&&j1>=len )
                    cout<<" "<<dic[i].s;
            }
        }
    }
}

int main()
{
    cnt = 0;
    while( cin>>dic[cnt++].s )
    {
        dic[cnt-1].len = strlen(dic[cnt-1].s);
        if( dic[cnt-1].s[0]=='#' )
        {
            cnt--;
            break;
        }
    }
    char st[20];
    while( cin>>st&&st[0]!='#' )
    {
        if( check(st)==1 )
            cout<<st<<" is correct"<<endl;
        else
        {
            cout<<st<<":";
            dell(st);
            cout<<endl;
        }
    }

    return 0;
}




  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值