ZOJ 3329 One Person Game(1)

Description

There is a very simple and interesting one-person game. You have 3 dice, namely Die1, Die2 and Die3. Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1, K2, K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers n, K1, K2, K3, a, b, c (0 <= n <= 500, 1 < K1, K2, K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698
 
  
解题思路:经典概率DP,解题思路见http://blog.csdn.net/morgan_xww/article/details/6775853,求解方法还是蛮经典的。
#include <ctime>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn = 610;
double p[maxn], pa[maxn], pb[maxn];
int T, n, k1, k2, k3, a, b, c;

/*
    经典概率DP
*/

int main() {

    scanf("%d", &T);
    while(T--) {
        scanf("%d %d %d %d %d %d %d", &n, &k1, &k2, &k3, &a, &b, &c);
        memset(p, 0, sizeof(p));
        memset(pa, 0, sizeof(pa));
        memset(pb, 0, sizeof(pb));
        double t = 1.0/(k1*k2*k3);
        for(int i = 1; i <= k1; ++i) {
            for(int j = 1; j <= k2; ++j) {
                for(int k = 1; k <= k3; ++k) {
                    if(i == a && j == b && k == c) continue;
                    p[i+j+k] += t;
                }
            }
        }
        for(int i = n; i >= 0; --i) {
            for(int j = 3; j <= k1+k2+k3 && i+j <= n;++j) {
                pa[i] += pa[i+j]*p[j];
                pb[i] += pb[i+j]*p[j];
            }
            pa[i] += t;
            pb[i] += 1.0;
        }
        printf("%.10lf\n", pb[0]/(1.0-pa[0]));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值