ZOJ 3471 Most Powerful

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22


解题思路:状态压缩DP,dp[i]表示i集合中的各种原子之间发生化学反应能够产生的最大的能量,我们便可以枚举最后两个反应的j,k,然后进行状态转移。


#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <utility>
#include <algorithm>
#include <functional>
using namespace std;
const int maxn = 11;
int w[maxn][maxn];
int dp[(1<<10)+10];
int n;

int main() {

    //freopen("aa.in", "r", stdin);

    while(scanf("%d", &n) != EOF) {
        if(n == 0) break;
        for(int i = 0; i < n; ++i) {
            for(int j = 0; j < n; ++j) {
                scanf("%d", &w[i][j]);
            }
        }
        memset(dp, -1, sizeof(dp));
        for(int i = 0; i < n; ++i) {
            dp[1<<i] = 0;
        }
        for(int i = 1; i < (1<<n); ++i) {
            if(dp[i] != -1) continue;
            for(int j = 0; j < n; ++j) {
                if(!(i&(1<<j))) continue;
                for(int k = 0; k < n; ++k) {
                    if(!(i&(1<<k)) || k == j) continue;
                    dp[i] = max(dp[i], dp[i^(1<<k)] + w[j][k]);
                }
            }
        }
        printf("%d\n", dp[(1<<n)-1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值