PAT A1067

1067. Sort with Swap(0,*) (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10 3 5 7 2 6 4 9 0 8 1
Sample Output:
9

此题的注意点就是录入序列的时候做一下预处理,即当录入到第i个数k时,令pos[k] = i;这样数组下标表示数值, 每一个数组元素表示该下标的位置,这样要想知道某个数的位置的时间复杂度就变为了O(1),而不再是O(n);

如果不这样处理,而使用O(n)复杂度的算法求位置的话,会有两组数据超时。

还有一点就是用next变量表示是否所有数字都已经回到正确位置,同时作为当0位于0时下一个可以交换的位置。

但是为什么当0位于位置0时,和任意一个没回到自己位置的数交换所得的结果是一样的呢?

如果刚好有大神知道,劳烦留个言解答一下小弟的困惑,不胜感激。

#include <cstdio>
#include <algorithm>
using namespace std;

int pos[100010];

int main(){
	int ans = 0;				 //当0位于位置0时,只需找到任意一个不在正确位置上的数交换位置即可让          循环继续下去,但是为什么是任意一个呢??
	int n, next = 1;                         //next当0位于位置0时,下一个交换的位置
	scanf("%d", &n);
	for(int i = 0; i < n; i++){
		int num;
		scanf("%d", &num);
		pos[num] = i;
	}
	while(next < n){
		while(pos[0] != 0){
			swap(pos[0], pos[pos[0]]);
			ans++;
		}
		while(pos[next] == next) next++;
		if(next < n){
			swap(pos[0], pos[next]);
			ans++;
		}
	}
	printf("%d\n", ans);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值