关于超时问题的讨论(hdu2139和hdu2132.)

这几天做到了有关超时问题的两道题:hdu2139和hdu2132.

2139题目:

Calculate the formula



Problem Description:You just need to calculate the sum of the formula: 1^2+3^2+5^2+……+ n ^2.
 Input:In each case, there is an odd positive integer n.
Output:Print the sum. Make sure the sum will not exceed 2^31-1
 

Sample Input
3
 

Sample Output
10
正确代码:
#include<stdio.h>
#include<math.h>
int main(){
int n;

long long int f[100001];
int i;
f[0]=0;
for(i=1;i<=100000;i=i+2){
f[i]=f[i-2]+pow(i,2);
}
while(scanf("%d",&n)!=EOF){
printf("%lld\n",f[n]);
}
return 0;
}
超时代码:
#include<stdio.h>
#include<math.h>
int main(){
int n;
while(scanf("%d",&n)!=EOF){
long long int sum=0;
int i;
for(i=1;i<=n;i+=2){
sum=sum+pow(i,2);
}
printf("%lld\n",sum);
}
return 0;
}
然后发现居然和hdu2132惊人的相似,也是把while(scanf()!=EOF)放在了最后面,然后数组那里也很像
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值