Uva10815 set容器的使用 stringstream ss

题目连接:http://acm.hust.edu.cn/vjudge/problem/18649

Sample Input

Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the
road.
The sign read: “Disneyland Left.” So they went home.

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

题意

就是按照字典序把每一个单词不重复地输出,不考虑大小写,全部转换为小写输出。

题解

略坑的地方,例如:“ffw.sef” ,这样是算作两个单词ffw和sef。

stringstream ss流处理的方法(新姿势)具体见代码 stringstream ss(s),可以把字符串s单独处理成每个单词

代码

#include<bits/stdc++.h>
using namespace std;
void tr(string &st)
{   string::iterator a;
    for(a=st.begin();a!=st.end();a++)
    {
        if(*a>='A'&&*a<='Z')*a=*a+32;
        else if(*a>='a'&&*a<='z')*a=*a;
        else {*a=' ';}
    }
}
int main()
{
    set<string> s;
    string zz,buf;
    while(cin>>zz)
    {
        tr(zz);
        stringstream ss(zz);
        while(ss>>buf)s.insert(buf);
    }
    set<string>::iterator it;
    for(it=s.begin();it!=s.end();it++)
    {
        cout<<*it<<"\n";
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值