错误:php70w-common conflicts with php-common-5.3.3-49.el6.x86_64 You could try using --skip-broken to

记录一下

  由于之前系统自带的php5.3.3没有卸载干净;

 

在执行phpize时报错说需要php-devel 

然后yum -y install php-delel ;

然后就报错

错误:php70w-common conflicts with php-common-5.3.3-49.el6.x86_64  You could try using --skip-broken to

 

解决办法;

yum -y install php70w-devel 

 

参考 https://www.xiegaosheng.com/post/view?id=81

已标记关键词 清除标记
<div class="post-text" itemprop="text"> <p>I am trying to install Laravel 5.6 in my new environment. </p> <p>In my local environment, I have everything set up just fine. When I go to deploy to Elastic Beanstalk, I am running into a problem where the dependencies are forcing the server back into PHP v7.0.33.</p> <p>How can the documentation of Laravel say that version 5.6 requires PHP 7.1.3 and up but the dependencies force me back to 7.0.33?</p> <p>Here is the dependency list for PHP from Composer (I removed unrelated dependencies):</p> <pre><code>composer/ca-bundle 1.1.4 requires php (^5.3.2 || ^7.0) composer/composer 1.8.4 requires php (^5.3.2 || ^7.0) composer/semver 1.4.2 requires php (^5.3.2 || ^7.0) composer/spdx-licenses 1.5.0 requires php (^5.3.2 || ^7.0) composer/xdebug-handler 1.3.2 requires php (^5.3.2 || ^7.0) filp/whoops 2.3.1 requires php (^5.5.9 || ^7.0) fzaninotto/faker v1.8.0 requires php (^5.3.3 || ^7.0) hamcrest/hamcrest-php v2.0.0 requires php (^5.3||^7.0) phar-io/manifest 1.0.3 requires php (^5.6 || ^7.0) phar-io/version 2.0.1 requires php (^5.6 || ^7.0) phpdocumentor/reflection-docblock 4.3.0 requires php (^7.0) phpdocumentor/type-resolver 0.4.0 requires php (^5.5 || ^7.0) phpspec/prophecy 1.8.0 requires php (^5.3|^7.0) ramsey/uuid 3.8.0 requires php (^5.4 || ^7.0) sebastian/code-unit-reverse-lookup 1.0.1 requires php (^5.6 || ^7.0) seld/jsonlint 1.7.1 requires php (^5.3 || ^7.0) theseer/tokenizer 1.1.0 requires php (^7.0) tijsverkoyen/css-to-inline-styles 2.2.1 requires php (^5.5 || ^7.0) webmozart/assert 1.4.0 requires php (^5.3.3 || ^7.0) </code></pre> <p>It seems to me that all these dependencies would not allow for an installation higher than the highest version of PHP 7.0. Am I reading this wrong? </p> </div>
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页