数位dp

数位问题:一般有三种状态,各个状态可以用前一个状态表示,此外一般从高位往低位方向处理

HDU  3555:Bomb
Bomb


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 16443    Accepted Submission(s): 6020

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 
Output
For each test case, output an integer indicating the final points of the power.
 
Sample Input
3
1
50
500

Sample Output
0
1
15

题意:找出1-N之间包含49的数字的个数

/*
* Author:xiaomo
* Date:2016.12.06
* Problem:找出1-n中包含49的个数
* Solution:
			dp[i][0] represent the numbers of not include 49 which length is i;
			dp[i][1] represent the numbers of not include 49 but start with 9,such as 91241;
			dp[i][2] represent the numbers of include 49 which length id i
			the status change function is:
			dp[i][0]=10*dp[i-1][0]-dp[i-1][1],if the number is started with 4 and length is i
			dp[i][1]=dp[i-1][0]
			dp[i][2]=10*dp[i-1][2]+dp[i-1][1]
*/

#include<iostream>
using namespace std;

typedef long long lint;

const int LENGTH = 21;
lint dp[LENGTH][3];

void init()
{
	dp[0][0] = 1;
	for (int i = 1; i < LENGTH; i++)
	{
		dp[i][0] = 10 * dp[i - 1][0] - dp[i - 1][1];            //不包括49
		dp[i][1] = dp[i - 1][0];                                //以9开头且不包含49
		dp[i][2] = 10 * dp[i - 1][2] + dp[i - 1][1];            //包含49
	}
}

lint work(lint number)
{
	int digit[21] = { 0 };
	int index = 0;
	while (number > 0)
	{
		digit[++index] = number % 10;
		number /= 10;
	}
	digit[index + 1] = 0;
	lint cnt = 0;
	bool flag = false;
	for (int i = index; i > 0; --i)    //from the highest order to lowest order
	{
		cnt += digit[i] * dp[i - 1][2];   //from 0-(digit[i]-1),the lower order include 49  
		if (flag)                      //the higher order include 49
		{
			cnt += digit[i] * dp[i - 1][0];
		}
		else
		{
			if (digit[i] > 4) 
			{
				cnt += dp[i - 1][1];
			}
		}
		if (digit[i + 1] == 4 && digit[i] == 9)
		{
			flag = true;
		}
	}
	return cnt;
}

int main()
{
	int length;
	cin >> length;
	lint number;
	init();
	for (int i = 0; i < length; i++)
	{
		cin >> number;
		cout << work(number + 1) << endl;   //pay attention:because include the number itself
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值