LightOJ 1138 Trailing Zeroes (III)(二分)

题目链接:https://vjudge.net/contest/373416#problem/D

题意:给出末尾有多少个0,问这是多少的阶乘。

思路:末尾有多少个0,就相当于求阶乘中有多少个5。

注:因为给出的末尾0的数据大,所以在查找的过程中需要使用二分查找。

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
ll judge(ll x)
{
    ll res=0;
    while (x)//求x中有多少个5
    {
        res+=x/5;
        x/=5;
    }
    return res;
}
ll solve(ll num)//二分查找
{
    ll L=1;
    ll R=0x3f3f3f3f;
    ll ans=-1;
    while (L<=R)
    {
        ll mid=(L+R)/2;
        ll s=judge(mid);
        if (s==num)
        {
            ans=mid;
            R=mid-1;
        }
        else if (s>num)
        {
            R=mid-1;
        }
        else if (s<num)
            L=mid+1;
    }
    return ans;
}
int main()
{
    int t;
    int o=1;
    scanf ("%d",&t);
    while (t--)
    {
        ll num;
        scanf ("%lld",&num);
        printf ("Case %d: ",o++);
        ll key=solve(num);
        if (key==-1)
            printf ("impossible\n");
        else
            printf ("%lld\n",key);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值