河南省第九届ACM程序设计竞赛。问题 F: Decimal integer conversion

题目链接:http://acm.codedream.ren/JudgeOnline/problem.php?cid=1001&pid=5

问题 F: Decimal integer conversion

时间限制: 1 Sec   内存限制: 64 MB
提交: 11   解决: 8

题目描述

XiaoMing likes mathematics, and he is just learning how to convert numbers between different bases , but he keeps making errors since he is only 6 years old. Whenever XiaoMing converts a number to a new base and writes down the result, he always writes one of the digits wrong. For example , if he converts the number 14 into binary (i.e., base 2), the correct result should be "1110", but he might instead write down "0110" or "1111". XiaoMing never accidentally adds or deletes digits, so he might write down a number with a leading digit of " 0" if this is the digit she gets wrong. Given XiaoMing 's output when converting a number N into base 2 and base 3, please determine the correct original value of N (in base 10). (N<=10^10) You can assume N is at most 1 billion, and that there is a unique solution for N. 

输入

The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8) Each test case specifies: * Line 1: The base-2 representation of N , with one digit written incorrectly. * Line 2: The base-3 representation of N , with one digit written incorrectly.

输出

For each test case generate a single line containing a single integer , the correct value of N

样例输入

  
  
1
1010
212

样例输出

14

题意:有一个n,他有一个n的错一位的二进制数字,还有一个n的错一位的三进制数字。求n是多少?
思路:暴力枚举出所有情况。
AC代码:
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
#include<map>
#include<string>
using namespace std;
typedef long long int ll;
const int mod = 1e7+7;
const int INF = 0x3f3f3f3f;
const int maxn = 5e4 +10;
int a[100];
int b[100];
char n[100];
char m[100];
int pow(int x,int y)
{
    int sum=1;
    for(int i=0; i<y; i++)
        sum*=x;
    return sum;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int nn=0,mm=0;
        scanf("%s%s",n,m);
        int ln=strlen(n);
        int lm=strlen(m);
        for(int i=0; i<ln; i++)
        {
            a[i]=n[i]-'0';
            nn+=pow(2,ln-i-1)*a[i];//nn表示二进制的值
        }
        for(int i=0; i<lm; i++)
        {
            b[i]=m[i]-'0';
            mm+=pow(3,lm-1-i)*b[i];//mm表示三进制的值
        }
        int ans=0;
        for(int i=0; i<ln; i++)
        {
            for(int ia=0; ia<2; ia++)
            {
                if(ia!=a[i])
                {
                    int nx=nn+(ia-a[i])*pow(2,ln-1-i);//更改二进制的第i位
 
                    for(int j=0; j<lm; j++)
                    {
                        for(int ib=0; ib<3; ib++)
                        {
                            if(ib!=b[j])
                            {
                                if(mm+(ib-b[j])*pow(3,lm-1-j)==nx)//更改三进制的第j位。
                                {
                                    ans=nx;
                                    break;
                                }
                            }
                        }
                        if(ans)
                            break;
                    }
 
                }
                if(ans)
                    break;
            }
            if(ans)
                break;
        }
        printf("%d\n",ans);
    }
}












  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值