最短路练习3/poj/1797/Heavy Transportation/dijkstar解法和并查集解法


题目链接:http://poj.org/problem?id=1797
Heavy Transportation
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 34931 Accepted: 9217

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题意:每条街道都有承受重量限制,从1点到n点最大重量限制是多少(超过这一重量都不能通过(即求最大值))

弄清楚边的大小关系。

并查集解法:AC代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
#include<map>
#include<string>
#define LL long long
using namespace std;
const int mod = 1e7+7;
const int inf = 0x3f3f3f3f;
const int maxn = 1e6 +10;
int t,n,m,ans,fa,fb,flag;
struct node
{
    int x,y,num;
} point[maxn];
int f[1005];
int cmp(node a,node aa)
{
    return a.num>aa.num;//从大到小排序,承重越小越不好,大的排在前。
}
int find(int x)
{
    return x==f[x]?x:f[x]=find(f[x]);递归找根节点,并且回溯更新父节点。
}
int main()
{
    flag=0;
    scanf("%d",&t);
    while(t--)
    {
        ans=0;
        scanf("%d%d",&n,&m);
        for(int i=0; i<=n; i++)
            f[i]=i;
        for(int i=0; i<m; i++)
            scanf("%d%d%d",&point[i].x,&point[i].y,&point[i].num);
        sort(point,point+m,cmp);
        for(int i=0; i<m; i++)
        {
            fa=find(point[i].x);
            fb=find(point[i].y);
            f[fa]=fb;
            if(find(1)==find(n))//如果1到n连通了直接跳出。
            {
                ans=point[i].num;
                break;
            }
        }
        if(flag++)
            printf("\n");
        printf("Scenario #%d:\n%d\n",flag,ans);
    }
}

dijkstar解法:AC代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
#include<map>
#include<string>
#define LL long long
using namespace std;
const int mod = 1e7+7;
const int inf = 0x3f3f3f3f;
const int maxn = 1e6 +10;
int t,n,m,a,b,c,flag;
int ma[1005][1005];
int vis[1005];//标记是否已经为最大值
int dis[1005];//dis[i]表示i到1的最大承重量(这个最大承重量是这条路的最小值,是点i到点1多条路的最大值)不懂的推一下样例
int main()
{
    flag=0;
    scanf("%d",&t);
    while(t--)
    {
        memset(ma,0,sizeof(ma));
        memset(vis,0,sizeof(vis));
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            ma[a][b]=c,ma[b][a]=c;//两个城市之间只有一条路,如果可能有多条路要加上if(c>ma[a][b])
        }
        dis[1]=0;
        vis[1]=1;
        for(int i=2;i<=n;i++)
            dis[i]=ma[i][1];
        int nn=n-2;
        while(nn--)
        {
             int sum=0,point=-1;
            for(int i=2;i<=n;i++)
            {
                if(!vis[i]&&dis[i]>sum)
                    sum=dis[i],point=i;//找出最大的承重量;
            }
            if(point!=-1)
            {
               vis[point]=1;
               for(int i=2;i<=n;i++)
               {
                   if(!vis[i]&&min(dis[point],ma[i][point])>dis[i])//更新到dis[i].
                    dis[i]=min(dis[point],ma[i][point]);
               }
            }
        }
        if(flag++)
            printf("\n");
        printf("Scenario #%d:\n%d\n",flag,dis[n]);
    }
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值