POJ 3264 Balanced Lineup 求线段树区间最值


http://poj.org/problem?id=3264
Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 53209 Accepted: 25021
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题意:求区间最大值和最小值的差。

思路:线段树(适合线段树刚入门的人)。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxx 200100
using namespace std;
struct node{
int l,r,mi,ma;
int mid(){return (l+r)>>1;}
}t[maxx];
int p;
int max(int a,int b)
{
    return a>b?a:b;
}
int min(int a,int b)
{
    return a>b?b:a;
}
void build(int rt,int l,int r)
{
    t[rt].l=l,t[rt].r=r;
    if(l==r)
    {
        scanf("%d",&p);
        t[rt].mi=t[rt].ma=p;
        return ;
    }
    int mid=(l+r)>>1;
    build(rt<<1,l,mid);
    build(rt<<1|1,mid+1,r);
    t[rt].mi=min(t[rt<<1].mi,t[rt<<1|1].mi);
    t[rt].ma=max(t[rt<<1].ma,t[rt<<1|1].ma);
    return ;
}
int querymi(int rt,int a,int b)
{
    if(t[rt].l==a&&t[rt].r==b)
    {
        return t[rt].mi;
    }
    int mid=t[rt].mid();
    if(b<=mid)
        return querymi(rt<<1,a,b);
    else if(a>mid)
        return querymi(rt<<1|1,a,b);
    else
        return min(querymi(rt<<1,a,mid),querymi(rt<<1|1,mid+1,b));
}
int queryma(int rt,int a,int b)
{
    if(t[rt].l==a&&t[rt].r==b)
    {
        return t[rt].ma;
    }
    int mid=t[rt].mid();
    if(b<=mid)
        return queryma(rt<<1,a,b);
    else if(a>mid)
        return queryma(rt<<1|1,a,b);
    else
        return max(queryma(rt<<1,a,mid),queryma(rt<<1|1,mid+1,b));
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        build(1,1,n);
        int a,b;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            printf("%d\n",queryma(1,a,b)-querymi(1,a,b));
        }
    }
}





  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值