HDU 1238 Substrings kmp暴力枚举

http://acm.hdu.edu.cn/showproblem.php?pid=1238

Substrings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10437    Accepted Submission(s): 4979


Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
 

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.
 

Output
There should be one line per test case containing the length of the largest string found.
 

Sample Input
  
  
2 3 ABCD BCDFF BRCD 2 rose orchid
 

Sample Output
  
  
2 2
题意 :现在有好多字符串,让你求他们的最长公共字符串,还有一个条件是:如果这个串只要有这个子串,或者是这个子串的倒序都可以(第二个样例很清楚,原串中or和ro只要有一个就可以)。

思路:因为这种题的数据量都不大所以,暴力枚举即可,枚举第一个串里所有的子串,每次用kmp求出这个串是否存在于其他串(正序或倒序)。

AC代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
const int maxx=105;
char a[maxx][maxx];
char b[maxx];
char c[maxx];
int la[maxx];
int nexb[maxx];
int nexc[maxx];
int n,lb;
void prekmp(char *r,int *l)//用指针来传参,r代表b或c数组,L代表nexb或nexc。
{
    int x=-1,y=0;
    l[0]=-1;
    while(y<la[0])
    {
        while(x!=-1&&r[x]!=r[y])
            x=l[x];
        l[++y]=++x;
    }
}
int kmp(int p,char *r,int *l)
{
    int x=0,y=0;
    while(y<la[p])
    {
        while(x!=-1&&r[x]!=a[p][y])
            x=l[x];
        ++x,++y;
        if(x==lb) return 0;
    }
    return 1;
}
int main()
{
    scanf("%d",&n);
    while(n--)
    {
        int m,ans=0;
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            scanf("%s",a[i]);
            la[i]=strlen(a[i]);
        }
        for(int i=0;i<la[0];i++)
        {
            for(int j=i;j<la[0];j++)
            {
                lb=0;
                for(int k=i;k<=j;k++)
                    b[lb++]=a[0][k];
                prekmp(b,nexb);
                lb=0;
                for(int k=j;k>=i;k--)
                    c[lb++]=a[0][k];
                prekmp(c,nexc);
                int h;
                for(h=1;h<m;h++)
                    if(kmp(h,b,nexb)&&kmp(h,c,nexc))break;//如果都找不到就break;
                if(h==m&&ans<lb)
                    ans=lb;
            }
        }
        printf("%d\n",ans);
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值