Substrings
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12505 Accepted Submission(s): 6014
Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.
Output
There should be one line per test case containing the length of the largest string found.
Sample Input
2
3
ABCD
BCDFF
BRCD
2
rose
orchid
Sample Output
2
2
Author
Asia 2002, Tehran (Iran), Preliminary
问题链接:HDU1238 Substrings
问题描述:给定一个字符串集合,求最长的字符串S,满足S或S的逆串是各个字符串的子串。
解题思路:按长度递减的顺序枚举第一个字符串的所有子串S,使用STL的reverse函数获得S的逆串S1,然后查看S或S1是否是其他所有字符串的子串。
AC的C++程序:
#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
const int N=105;
string s[N];
int main()
{
int t,n;
cin>>t;
while(t--)
{
cin>>n;
for(int i=0;i<n;i++)
cin>>s[i];
//枚举s[0]的每个子串 按长度递减顺序
int ans=0;
bool flag=false;
for(int l=s[0].length();l>0&&!flag;l--)//子串长度
{
for(int i=0;i+l<=s[0].length();i++)//子串起始位置
{
string s1=s[0].substr(i,l);
string s2=s1;//s2存储s1的逆串
reverse(s2.begin(),s2.end());//反转
bool flag2=true;//进行查找
//查看其他各个子串中是否含有s1或者s2
for(int j=1;j<n;j++)
if(s[j].find(s1,0)==-1&&s[j].find(s2,0)==-1)
{
flag2=false;
break;
}
if(flag2)
{
ans=l;
flag=true;//找到答案
break;
}
}
}
printf("%d\n",ans);
}
return 0;
}