HDU 2819 Swap 二分匹配 (思路题)

传送门:Swap

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3576    Accepted Submission(s): 1312
Special Judge

Problem Description
Given an N*N matrix with each entry equal to 0 or 1. You can swap any two rows or any two columns. Can you find a way to make all the diagonal entries equal to 1?
 

Input
There are several test cases in the input. The first line of each test case is an integer N (1 <= N <= 100). Then N lines follow, each contains N numbers (0 or 1), separating by space, indicating the N*N matrix.
 

Output
For each test case, the first line contain the number of swaps M. Then M lines follow, whose format is “R a b” or “C a b”, indicating swapping the row a and row b, or swapping the column a and column b. (1 <= a, b <= N). Any correct answer will be accepted, but M should be more than 1000.

If it is impossible to make all the diagonal entries equal to 1, output only one one containing “-1”.
 

Sample Input
  
  
2 0 1 1 0 2 1 0 1 0
 

Sample Output
  
  
1 R 1 2 -1
题意:给你一个矩阵,让你交换任意两行,或者是任意两列,次数不限,若可以使得主对角线上的数字都为1,则输出你交换的是那些行,交换的是那些列,若不可行则输出-1。

交换a和b两行输出R a b表示

交换a和b两列输出C a b表示

思路:若你只交换行(hang)不行(xing)的话,那么你交换列也是不行的,行(hang)列都交换也不行(xing),

所以你只用试着交换行,或者列即可;

AC代码:

#include<iostream>
#include <cstdio>
#include<algorithm>
#include<map>
#include<cmath>
#include<cstring>
#define LL long long
#define mod 10007
#define N 105
using namespace std;
int n;
int g[N][N];
int x[N];
int vis[N];
int k[N][N];
struct node
{
    int a,b;
}ans[N];
int find(int v)
{
    for(int i=1; i<=n; i++)
    {
        if(g[v][i]&&!vis[i])
        {
            vis[i]=1;
            if(!x[i]||find(x[i]))
            {
                x[i]=v;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(g,0,sizeof(g));
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                scanf("%d",&g[i][j]);
        int flag=0;
        memset(x,0,sizeof(x));
        for(int i=1; i<=n; i++)
        {
            memset(vis,0,sizeof(vis));
            if(!find(i))
            {
                flag=1;
                break;
            }
        }
        if(flag)   printf("-1\n");
        else
        {
            int sum=0,j;
            for(int i=1; i<=n; i++)
            {
                for(j=i;j<=n;j++)
                {
                    if(x[j]==i)
                        break;
                }
                    if(i==j) continue;
                    ans[sum].a=i;
                    ans[sum].b=j;
                    sum++;
                    swap(x[i],x[j]);
            }
            printf("%d\n",sum);
            for(int i=0; i<sum; i++)
               printf("C %d %d\n",ans[i].a,ans[i].b);
        }
    }
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值