POJ - 3258【二分】

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18158 Accepted: 7571

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di

Any problem, Please Contact Administrator

题意:就是有一头牛要跳着石块过河,去掉其中m个石块,问去掉石块后牛应该跳的最小距离的最大值是多少。

这道题就是先找出石块间的距离,设sum为去掉一个石块后剩下一个石块到前一个石块的距离,如果sum<mid(二分的值)则继续去掉下一个石块,如果sum>mid说明这个石块不能去掉,然后继续从这个石块接着查找,同时sum=0;这道题属于最小值最大化问题。

 

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
/*bool cmp(int a,int b){
	return a<b;
} */
int n,m;
int a[500005];
bool judge(int x){
	int ans=0,sum=0;
	for(int i=1;i<=n;i++){
		sum=sum+a[i]-a[i-1];
		if(sum<x){
			ans++;
		}
		else{
			sum=0;
		}
	}
	if(ans<=m) return true;
	else  return false;
}
int main(){
	int l;
	while(~scanf("%d%d%d",&l,&n,&m)){
		//memset(a,0,sizeof(a)); 
		int mind;
		/*a[0]=0;
		a[n+1]=l;*/
		for(int i=1;i<=n;i++){
			scanf("%d",&a[i]);
		}
		sort(a+1,a+n+1);
		mind=l;
		for(int i=1;i<=n;i++){
			//a[i]=a[i]-a[i-1];
			mind=min(mind,a[i]-a[i-1]);
		}
		int left=mind,right=l; 
		int minn;
		while(right>=left){
			int mid=(right+left)/2;
			if(judge(mid)){
				minn=mid;//二分答案 
				left=mid+1;//如果满足条件则缩小上界 ,应为要找最大值,要
				//不断缩小下界逼近最大值 
			}
			else right=mid-1;//缩小下节 
		} 
		printf("%d\n",minn);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值