LightOJ - 1370 ——Bi-shoe and Phi-shoe【素数筛法,欧拉函数】

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题目大意:就是让你去买一些竹子,每根柱子的分数等于该竹子的长度的欧拉函数值,要给一些孩子买竹子,并且这些孩纸每一个都有一个幸运值,要保证每个孩子的竹子的分数大于或等于孩子的幸运值。

这道题我最开始的思路是:先用欧拉函数打表没求助2~n的每一个数的函数值,在去求每一个竹子长度,然后就时间超限了。。。。后来看大佬们的博客才明白,如果n为素数则phi(n)=n-1,查找大于每一个幸运值(temp),直接查找temp+1之后的最小的素数就可以了。

#include<algorithm>
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
const int MAXN=1000005;
//int phi[MAXN];
//找出0~n每一个函数的欧拉值
/*void euler(int n){
    for(int i=2;i<=n;i++) phi[i]=i;
    for(int i=2;i<=n;i++){
        if(phi[i]==i){
            for(int j=i;j<=n;j=j+i){
                phi[j]=phi[j]/i*(i-1);
            }
        }
    }
}*/
int pre[MAXN];
void init_pre(){
    memset(pre,1,sizeof(pre));
    pre[0]=pre[1]=0;
    for(int i=2;i<=sqrt(MAXN*1.0);i++){
        if(pre[i]){
            for(int j=i*i;j<MAXN;j=j+i){
                pre[j]=0;
            }
        }
    }
}
int main(){
    int t,n;
    scanf("%d",&t);
    int kase=0;
    init_pre();
    while(t--){
       //euler(MAXN);
        //init_pre();
        scanf("%d",&n);
        long long ans=0;
        int t;
        for(int i=1;i<=n;i++){
            scanf("%d",&t);
            for(int j=t+1;j<=MAXN;j++){
               if(pre[j]){
                ans=ans+j;
                break;
               }
            }
        }
        printf("Case %d: %lld Xukha\n",++kase,ans);
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值