poj2398——Toy Storage【计算几何,叉积判断方向】

Toy Storage

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6661 Accepted: 3972

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 


We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

Source

Tehran 2003 Preliminary

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator

这道题和之前poj2318那道题很像,不过不同的是这个问的是点数为x的点有多少个,并且这道题的注意,这里面的每一条线都是无序的要排一下序。

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
const int MAXN=100005;
int n,m,maxx;
int total[MAXN],vis[MAXN];
struct Point{
    int x,y;
};
struct Line{
    Point a,b;
}line[MAXN];
int det(Point p0,Point p1,Point p2){
    return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}
bool cmp(Line l1,Line l2){
    return l1.a.x<l2.a.x;//把每一条线排序
}
void judge(Point d){
    int i;
    for(i=0;i<n;i++){
        if(det(line[i].b,d,line[i].a)>0){
            continue;
        }
        else{
            total[i]++;
            maxx=max(maxx,total[i]);
            return ;
        }
    }
    total[n]++;
    maxx=max(total[i],maxx);
    return ;
}
int search_x(int s){
    int sum=0;
    for(int i=0;i<=n;i++){
        if(vis[i]||!total[i]||total[i]!=s) continue;
        vis[i]=1;//标记次块区域已经查找过
        sum++;//如果有点在该区域中
    }
    return sum;
}
int main(){
    int sum;
    Point up_left,low_right,te;
    while(~scanf("%d",&n)&&n){
        scanf("%d%d%d%d%d",&m,&up_left.x,&up_left.y,&low_right.x,&low_right.y);
        memset(vis,0,sizeof(vis));
        memset(total,0,sizeof(total));
        for(int i=0;i<n;i++){
            scanf("%d%d",&line[i].a.x,&line[i].b.x);
            line[i].a.y=up_left.y;
            line[i].b.y=low_right.y;
        }
        sort(line,line+n,cmp);
        maxx=-1;
        for(int i=0;i<m;i++){
            scanf("%d%d",&te.x,&te.y);
            judge(te);
        }
        printf("Box\n");
        for(int i=1;i<=maxx;i++){
            sum=0;
            sum=search_x(i);
            if(sum==0) continue;
            else{
                printf("%d: %d\n",i,sum);
            }
        }
    }
    return 0;
}



 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值