HDU1241——Oil Deposits【DFS求联通区域数量】

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42171    Accepted Submission(s): 24453


 

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

 

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

 

Sample Input

 

1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0

 

 

Sample Output

 

0 1 2 2

 

 

Source

Mid-Central USA 1997

 题目大意:每个竖着,横着,斜着相连的@可以构成一个油田,问一共有多少块油田。

题目思路:这道题可以参考挑战程序设计竞赛第2版P33页求八联通那道题,解法相同。可以把每一个@点及其周围的@都变为*最后在看DFS共进行了几次。

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN=110;
int n,m,res;
char mp[MAXN][MAXN];
//int dir[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
int dx[8]={-1,-1,-1,0,0,1,1,1},dy[8]={-1,0,1,-1,1,-1,0,1};
void DFS(int x,int y){
    mp[x][y]='*';//将当前位置替换成*说明这个位置已经搜过了
    for(int i=0;i<8;i++){
        int nx=x+dx[i];
        int ny=y+dy[i];
        if(mp[nx][ny]=='@'&&nx>=0&&nx<n&&ny>=0&&ny<m) DFS(nx,ny);
    }
    return ;//枚举完一个点的八个方向后结束搜索
}
int main(){
    while(~scanf("%d%d",&n,&m)&&n,m){
        for(int i=0;i<n;i++) scanf("%s",mp[i]);
        res=0;
        //枚举所有符合情况的点
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                if(mp[i][j]=='@'){
                    DFS(i,j);
                    res++;
                }
            }
        }
        printf("%d\n",res);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值