POJ2752——Seek the Name, Seek the Fame 【KMP】

 

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题目大意:给你一组字符串,当这组字符串的前缀和后缀相同时, 输出其前缀的长度。

大致思路:首先我们要明白KMP算法中next数组的作用,next[i]表示在字符串A中,以i为结尾的非前缀子串与A的前缀能够匹配的最长长度。

假设字符串的长度为len,那么next[len]就表示字符串的后缀与A的前缀的匹配的最长长度。我们可以从这一步得到A的前缀串长度,然后在在next[len]中去查找下一个前缀串,因为下一个前缀串一定落在next[len]中,按找上一步的方法继续去求解与之相匹配的后缀串的长度。这个时候我们要知道上一步求的前缀串一定与后缀串想等,所以在next[len]中求解的的后缀串在原字符串中一定能查找到。然后我们就按找这个思路递归查找。知道找到头为止。同时注意字符串A的前缀和后缀的最大匹配为它自己。

如果无法理解的话我们可以结合这幅图片理解:

图中黑色部分表示原字符串,红色部分表示next[len],蓝色部分表示next[next[len]]。

Talk is cheap,show me the code!

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN=1e6+10;
int next[MAXN],sum[MAXN];
char a[MAXN];
int n;
void getNext(){
	next[1]=0;
	for(int i =2, j = 0;i <= n; i++){
		while(j > 0 && a[i] != a[j+1]) j = next[j];
		if(a[i] == a[j+1]) j++;
		next[i]=j;
	}
}
int main(){
	while(~scanf("%s",a+1)){
		n = strlen(a+1);
		int k = 0;
		getNext();
		for(int i = next[n];i != 0; i = next[i]){
			sum[k++] = i;
		}
		for(int i = k-1; i >= 0;i--){
			printf("%d ",sum[i]);
		}
		printf("%d\n", n);
	}
	return 0;
}

 

基于STM32F407,使用DFS算法实现最短迷宫路径检索,分为三种模式:1.DEBUG模式,2. 训练模式,3. 主程序模式 ,DEBUG模式主要分析bug,测量必要数据,训练模式用于DFS算法训练最短路径,并将最短路径以链表形式存储Flash, 主程序模式从Flash中….zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值