UVA - 10935——Throwing cards away 【队列,模拟】

5 篇文章 0 订阅

Given is an ordered deck of n cards numbered 1to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck:

        Throw away the top card and move

        the card that is now on the top of the

        deck to the bottom of the deck.

  Your task is to find the sequence of discarded cards and the last, remaining card.

Input

Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed.

Output

For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format.

Sample Input

7

19

10

6

0

Sample Output

Discarded cards: 1, 3, 5, 7, 4, 2

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8

Remaining card: 4

Discarded cards: 1, 3, 5, 2, 6

Remaining card: 4

题目大意:给你N张卡片,每张按照1~n编号,当至少还剩下两张牌是进行一下操作:把第一张牌扔掉,然后把新的第一张牌放到整叠牌的最后。

大致思路:按照题目思路用队列一步步模拟即可。

#include <bits/stdc++.h>
using namespace std;

queue<int> qu;

int main(){
	int n;
	while(~scanf("%d",&n)&&n){
		while(!qu.empty()) qu.pop();
		for(int i = 1; i <= n; i++){
			qu.push(i);
		}
		bool flag = false;
		printf("Discarded cards:");
		while(qu.size() >= 2){
			if(flag){
				printf(",");
			}
			flag = true;
			printf(" %d",qu.front());
			qu.pop();
			qu.push(qu.front());
			qu.pop();
		}
		printf("\n");
		printf("Remaining card: %d\n",qu.front());
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值