uva1593—— Alignment of Code 【stl,模拟】

17 篇文章 0 订阅
11 篇文章 0 订阅

You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p1 = 1; the second words on each line are printed at the minimal possible position p2, such that all first words end at or before position p2 − 2; the third words on each line are printed at the minimal possible position p3, such that all second words end at or before position p3 − 2, etc. For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

Input

The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

Output

Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that i-th word on each line starts at the same position pi . Note for the Sample: The ‘⊔’ character in the example below denotes a space character in the actual files (ASCII code 32).

Sample Input 

␣␣start:␣␣integer;␣␣␣␣//␣begins␣here

stop:␣integer;␣//␣␣ends␣here

␣s:␣␣string;

c:␣␣␣char;␣//␣temp 

Sample Output

start:␣integer;␣//␣begins␣here

stop:␣␣integer;␣//␣ends␣␣␣here

s:␣␣␣␣␣string;

c:␣␣␣␣␣char;␣␣␣␣//␣temp

题目大意:给你一些字符,让你把这组字符按样例所给形式对其输出。

大致思路:我们可以用vector储存一个单词矩阵,然后找单词矩阵每一列的最大长度,格式化输出就行了。

首先就是这道题的输入问题,我们可以getline把字符按行输入,在用stringstream最字符进行格式化存入vector中。最后输出的时候我们要调用#include <iomanip> 中的setw函数进行格式化输出。

至于setw,和stringstream的应用可以参考一下两片博客。

stringstream的使用

setw的使用 

接下来就是代码了:

#include <iomanip>
#include <bits/stdc++.h>
using namespace std;
vector<string> word[100010];
int maxlen[100010];
int main(){
    string s,t;
    int k = 0;
    memset(maxlen,0,sizeof(maxlen));
    while(getline(cin,s)){
        //按行读入每一个字符
        stringstream ss(s); //把每一个字符转化为标准形式
        //string t;
       // int k = 0;
        int i = 0;
        while(ss >> t){
           // cout<<t<<endl;
            maxlen[i] = max((int)t.length(),maxlen[i]);
            word[k].push_back(t);
           // cout<<t<<endl;
            //printf("%d\n",k);
            i++;
        }
        k++;
    }
  //  printf("%d\n",k);
    cout << setiosflags(ios::left);
    for(int i = 0; i < k; i++){
        int j;
        for(j = 0; j < (int)word[i].size()-1; j++){
            cout<<setw(maxlen[j] + 1)<<word[i][j];
        }
        cout << word[i][j] <<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值