HDU2609——How many【最小表示法,set去重】

How many

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4190    Accepted Submission(s): 1925


 

Problem Description

Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.

 

 

Input

The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').

 

 

Output

For each test case output a integer , how many different necklaces.

 

 

Sample Input

 

4 0110 1100 1001 0011

4 1010 0101 1000 0001

 

 

Sample Output

 

1 2

 

 

Author

yifenfei

 

 

Source

奋斗的年代

 

题目大意:给你n个收尾项链,问有多少个项链是相同的。 

大致思路:如果有两个项链是相同的则他们的最小表示法一定相同。可以求出所有项链的最小表示法,然后存入集合中,最后返回集合的大小就行了。

#include <bits/stdc++.h>
using namespace std;

const int MAXN = 1e4+10;
string s1[MAXN];
string s2[MAXN];
set<string> se;

int GetMinId(string a){
	int n = a.size();
	int i = 0, j = 1, k = 0;
	while(i < n && j < n && k < n){
		int t = a[(i + k) % n] - a[(j + k) % n];
		if(t == 0) k++;
		else{
			if(t > 0) i += k + 1;
			else j += k + 1;
			if(i == j) j++;
			k = 0;
		}
	}
	return min(i,j);
}

int main(int argc, char const *argv[])
{
	int n;
	while(~scanf("%d",&n)){
		for(int i = 0; i < n; i++){
			cin >> s1[i];
			s2[i] = s1[i] + s1[i];
		}
		//for(int i = 0; i < n; i++) cout << s2[i] << endl;
		for(int i = 0; i < n; i++){
			int ans = GetMinId(s1[i]);
			//cout << ans << endl;
			//cout << s2[i].substr(ans,s1[i].size()) << endl;
			se.insert(s2[i].substr(ans,s1[i].size()));
		}
		cout << se.size() << endl;
		se.clear();
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值