UVA 12325—— Zombie's Treasure Chest【枚举,暴力】

3 篇文章 0 订阅
1 篇文章 0 订阅

Some brave warriors come to a lost village. They are very lucky and find a lot of treasures and a big treasure chest, but with angry zombies. The warriors are so brave that they decide to defeat the zombies and then bring all the treasures back. A brutal long-drawn-out battle lasts from morning to night and the warriors find the zombies are undead and invincible. Of course, the treasures should not be left here. Unfortunately, the warriors cannot carry all the treasures by the treasure chest due to the limitation of the capacity of the chest. Indeed, there are only two types of treasures: emerald and sapphire. All of the emeralds are equal in size and value, and with infinite quantities. So are sapphires. Being the priest of the warriors with the magic artifact: computer, and given the size of the chest, the value and size of each types of gem, you should compute the maximum value of treasures our warriors could bring back.

Input

There are multiple test cases. The number of test cases T (T ≤ 200) is given in the first line of the input file. For each test case, there is only one line containing five integers N, S1, V1, S2, V2, denoting the size of the treasure chest is N and the size and value of an emerald is S1 and V1, size and value of a sapphire is S2, V2. All integers are positive and fit in 32-bit signed integers.

Output

For each test case, output a single line containing the case number and the maximum total value of all items that the warriors can carry with the chest.

Sample Input

2

100 1 1 2 2

100 34 34 5 3

Sample Output Case #1:

100

Case #2:

86

题目大意:给你体积为N的箱子和体积为S1,价值为V1,体积为S2,价值为V2的两种宝物,两种宝物的数量不限,问怎么拿才能是价值最大。

题目大致思路:首先当n与s1相差不是特别大时我们可以尽可能多的拿s1,剩下的拿s2.当n与s2相差的不是特别大的时候也是如此。当n与s1,s2都相差特别大时。我们比较一下v1\tfrac{n}{s1}v2\tfrac{n}{s2}的大小及v1 * s2与s1 * v2的大小,相当于直接拿s2个v1,s1个v2。然后如果v1 * s2小我们救赎要拿s1,枚举所有s1的拿法并且不断更新最大值,当v2 * s1较小时同理。

#include <bits/stdc++.h>

using namespace std;

#define INF 5000
typedef long long LL;

int main(int argc, char const *argv[])
{
	int t;
	scanf("%d",&t);
	int kase = 0;
	while(t--){
		LL n,s1,v1,s2,v2;
		scanf("%lld %lld %lld %lld %lld",&n,&s1,&v1,&s2,&v2);
		LL ans = -1;
		printf("Case #%d: ",++kase);
		//枚举宝物1的个数
		if((n / s1) < INF){
			for(LL i = 0; i * s1 <= n; i++){
				LL temp = n - i * s1;
				ans = max(ans,i * v1 + temp / s2 * v2);
			}
			printf("%lld\n",ans);
		}
		//枚举宝物2
		else if((n / s2) < INF){
			for(LL i = 0; i * s2 <= n; i++){
				LL temp = n - i * s2;
				ans = max(ans,i * v2 + temp / s1 * v1);
			}
			printf("%lld\n",ans);
		}
		//第二种枚举方案
		else{
			if(s2 * v1 <= s1 * v2){
				for(LL i = 0; i <= s1; i++){
                    LL temp = n;
                    temp -= i * s2;
                    ans = max(ans,i * v2 + temp / s1 * v1);
				}
				printf("%lld\n",ans);
			}
			else{
				for(LL i = 0; i <= s2; i++){
                    LL temp = n;
                    temp -= i * s1;
                    ans = max(ans,i * v1 + temp / s2 * v2);
				}
				printf("%lld\n",ans);
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值