输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。
Input输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。
Output对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。Sample Input
3 3 -4 2 4 0 1 2 -3 0Sample Output
-4 3 2 -3 2 1 0
利用cmath 库中的abs 可以直接判断
实现代码如下
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int a[101];
int n,i=0;
while(cin>>n)
{
if(n==0) break;
else
{
for(i=0;i<n;i++)
{
cin>>a[i];
}
for(i=1;i<n;i++)
{
for(int j=0;j<n-i;j++)
{
if(abs(a[j])<abs(a[j+1]))
{
int temp;
temp=a[j];
a[j]=a[j+1];
a[j+1]=temp;
}
}
}
for(i=0;i<n;i++)
{
cout<<a[i];
if(i!=n-1)cout<<" ";
}
cout<<endl;
}
}
}