1020. Tree Traversals (25)——PAT (Advanced Level) Practise

题目信息

1020. Tree Traversals (25)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

解题思路

递归模拟建树,同时保存每层节点,注意,并未真正建树

AC代码

#include <cstdio>
#include <vector>
using namespace std;
int n, in[35], post[35];
vector<int> level[31];
void build(int inid, int postid, int len, int lv){
    if (len <= 0) return;
    int root = postid + len -1;
    int rid = inid;
    while (in[rid] != post[root]) ++rid;
    level[lv].push_back(post[root]);
    build(inid, postid, rid - inid, lv+1);
    build(rid + 1, postid + rid - inid, len - (rid - inid) - 1, lv+1);
}
int main()
{
    scanf("%d", &n);
    for (int i = 1; i <= n; ++i){
        scanf("%d", post+i);
    }
    for (int i = 1; i <= n; ++i){
        scanf("%d", in+i);
    }
    build(1, 1, n, 0);
    printf("%d", post[n]);
    for (int i = 1; i <= 30; ++i){
        for (int j = 0; j < level[i].size(); ++j){
            printf(" %d", level[i][j]);
        }
    }
    printf("\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值