1026. Table Tennis (30)【排序+模拟+逻辑复杂】——PAT (Advanced Level) Practise

题目信息

1026. Table Tennis (30)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B

A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.

Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.

One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (<=10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players’ info, there are 2 positive integers: K (<=100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains M table numbers.

Output Specification:

For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.

Sample Input:
9
20:52:00 10 0
08:00:00 20 0
08:02:00 30 0
20:51:00 10 0
08:10:00 5 0
08:12:00 10 1
20:50:00 10 0
08:01:30 15 1
20:53:00 10 1
3 1
2
Sample Output:
08:00:00 08:00:00 0
08:01:30 08:01:30 0
08:02:00 08:02:00 0
08:12:00 08:16:30 5
08:10:00 08:20:00 10
20:50:00 20:50:00 0
20:51:00 20:51:00 0
20:52:00 20:52:00 0
3 3 2

解题思路

维护用户队列、空闲桌子队列和桌子到期队列。
注意:超过两小时需截断,等待时间需四舍五入,8点前需等待,21点关门

AC代码

#include <cstdio>
#include <vector>
#include <set>
#include <queue>
#include <functional>
using namespace std;
bool table[10005], isvip[10005];
int tableTimes[10005];
struct node{
    int arriveTime, useTime;
    bool vip;
    node(){}
    node(int t, int tu, bool v):arriveTime(t), useTime(tu), vip(v){}
    bool operator<(const node& b)const{
        return arriveTime < b.arriveTime;
    }
};
bool operator<(const pair<int,int> &a, const pair<int,int> &b){
    return a.first < b.first;
}
set<node> arriveList; //顾客到达列表
priority_queue<pair<int, int>, vector<pair<int,int> >, greater<pair<int,int> > > que; //乒乓球台到期队列
set<int> freeList; //空闲台队列

int main()
{
    int n, tableNum, tableVipNum, tableVipNow,a, b, c, t, vip;
    int nowTime = 8*3600;
    scanf("%d", &n);
    for (int i = 0; i < n; ++i){
        scanf("%d:%d:%d%d%d", &a, &b, &c, &t, &vip);
        arriveList.insert(node(a*3600 + b*60 + c, t, vip == 1));
    }
    scanf("%d%d", &tableNum, &tableVipNum);
    for (int i = 0; i < tableNum; ++i){
        freeList.insert(i);//初始化空闲台
    }
    tableVipNow = tableVipNum;
    for (int i = 0; i < tableVipNum; ++i){
        scanf("%d", &vip);
        isvip[vip-1] = true;
    }
    while (!arriveList.empty() && nowTime < 21*3600){
        t = arriveList.begin()->arriveTime;
        if (!freeList.empty() && t <= nowTime){
            if (tableVipNow > 0){
                set<node>::iterator it = arriveList.begin();
                while (it != arriveList.end() && nowTime >= it->arriveTime){
                    if (it->vip){
                        break;
                    }
                    ++it;
                }
                if (it != arriveList.end() && nowTime >= it->arriveTime){
                    --tableVipNow;
                    set<int>::iterator itable = freeList.begin();
                    while (!isvip[*itable]){
                        ++itable;
                    }
                    t = it->arriveTime;
                    printf("%02d:%02d:%02d %02d:%02d:%02d %d\n", t/3600, t%3600/60, t%60, nowTime/3600, nowTime%3600/60, nowTime%60, (nowTime - t + 30)/60); //四舍五入
                    tableTimes[*itable]++;
                    que.push(make_pair(nowTime + min(120, it->useTime) * 60, *itable)); //超过两小时截断
                    freeList.erase(*itable);
                    arriveList.erase(*it);
                    continue;
                }
            }
            printf("%02d:%02d:%02d %02d:%02d:%02d %d\n", t/3600, t%3600/60, t%60, nowTime/3600, nowTime%3600/60, nowTime%60, (nowTime - t + 30)/60);
            tableTimes[*freeList.begin()]++;
            que.push(make_pair(nowTime + min(120, arriveList.begin()->useTime) * 60, *freeList.begin())); //截断
            if (isvip[*freeList.begin()]){
                --tableVipNow;
            }
            freeList.erase(*freeList.begin());
            arriveList.erase(*arriveList.begin());
            continue;
        }else {
            if (que.empty() || (!freeList.empty() && que.top().first > t)){
                nowTime = t;
            }else{
                if (nowTime < que.top().first){
                    nowTime = que.top().first;
                }
                while (!que.empty() && nowTime >= que.top().first){
                    freeList.insert(que.top().second);
                    if (isvip[que.top().second]) {
                        ++tableVipNow;
                    }
                    que.pop();
                }
            }
        }
    }
    printf("%d", tableTimes[0]);
    for (int i = 1; i < tableNum; ++i){
        printf(" %d", tableTimes[i]);
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值