pip安装需要的各种库

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/xiaoYAN174/article/details/64920742

安装好python3.5+pycharm后,需要安装需要的各种库,在此总结一下:

1.numpy+MKL 

2.scipy

3.matplotlib

4.scikit-learn

..........

其中如果直接pip安装numpy的话,是不带mkl的,因此这里需要手动安装(到这里下载匹配的),然后pip install "****.whl"。这里需要注意的是,安装文件的名字下载下来可能与源文件的不符,安装时会出现.whl is not a valid wheel filename,这时你需要手动改一下文件名称,改成和下载目录完全一样的名称。

安装好numpy+mkl后,scipy类似,其他的都可以pip install matplotlib或pip install scikit-learn了(直接pip安装,不需要下载了)。

还有,最好按顺序安装。

展开阅读全文

没有更多推荐了,返回首页